Поиск книг в интернет магазине Болеро

Поиск DVD в интернет магазине DVD DOM
Внимание! Money-Hunting.Ru - Интересная Online Игра с Денежными Призами.

WORD

  • Занятие 1. Создание и разметка документа
    • Создание документа
      • Упражнение 1. Шаблоны
      • Упражнение 2. Мастер создания документа
    • Режимы просмотра
      • Упражнение 3. Обычный режим
      • Упражнение 4. Разметка страницы
      • Упражнение 5. Структура документа
    • Контрольное упражнение
    • Подведение итогов
  • Занятие 2. Оформление документа
    • Параметры абзаца
      • Упражнение 1. Отступы, интервалы и табуляции
      • Упражнение 2. Списки и столбцы
    • Форматирование текста
      • Упражнение 3. Выбор шрифта
      • Упражнение 4 .Табуляция
      • Упражнение 5. Стиль
    • Графические объекты
      • Упражнение 6. Фигуры и надписи
      • Упражнение 7. Библиотека картинок
    • Контрольное упражнение
    • Подведение итогов
  • Занятие 3. Таблицы и графики
    • Таблицы
      • Упражнение 1. Добавление таблицы
      • Упражнение 2. Размер ячеек
      • Упражнение 3. Разбиение и объединение ячеек
      • Упражнение 4. Форматирование таблицы
    • Графики и диаграммы
      • Упражнение 5. Построение диаграммы на базе таблицы
      • Упражнение 6. Форматирование диаграмм и графиков
    • Контрольное упражнение
    • Подведение итогов
  • Занятие 4. Дополнительные возможности Word
    • Орфография и грамматика
      • Упражнение 1. Язык документа
      • Упражнение 2. Проверка орфографии и грамматики
    • Слияние
      • Упражнение 3. Создан не главного документа
      • Упражнение 4. Построение источника данных
      • Упражнение 5. Размещение полей данных
      • Упражнение 6. Печать результата слияния
    • Контрольное упражнение
    • Подведение итогов


Занятие №1

Word

Microsoft Word XP — один из лучших текстовых редакторов. Он позволяет создавать и редактировать документы, добавлять в них таблицы и рисунки, изменять оформление абзацев и начертание шрифта, готовить документ к печати. Дополнительные модули Word позволяют выполнять такие операции, как проверка орфографии и грамматики, формирование оглавлений и указателей, слияние с базой данных.

Создание и разметка документа

ТЕМА ЗАНЯТИЯ

Вторая часть книги посвящена описанию приложения Word — мощного текстового процессора. На этом занятии вы познакомитесь с шаблонами документов, научитесь экспортировать файлы Word в формат HTML и познакомитесь с четырьмя режимами просмотра документов, которые перечислены ниже:

  • обычный режим;

  • разметка страницы;

  • структура документа;

  • электронный документ.

Современную жизнь нельзя представить без обилия текстовых документов в бумажном и электронном виде. Word XP — это современная версия популярного текстового процессора, позволяющая писать письма, форматировать тексты любой сложности, добавлять в них рисунки, формулы и графики и даже верстать целые книги. Сегодня формат документов Word стал общепризнанным. Вы можете отправить такой документ по электронной почте в любую точку земного тара, и практически везде его смогут прочесть.


Создание документа

В первой части книги вы уже научились создавать и открывать простейшие документы Word. Сейчас пришло время познакомиться с шаблонами и мастерами, генерирующими стандартное содержание и общее оформление документов. Наличие такого предварительно настроенного документа облегчает процесс ввода конкретного текста.


Упражнение 1. Шаблоны

Шаблоны можно рассматривать как обычные документы Word, в которых кроме текста и списка стилен хранится информация о конфигурации панелей инструментов, макросы и параметры, определяющие вид документа и поведение программы. Шаблоны очень удобны, когда ряд документов требуется оформить в одинаковом стиле. Однажды настроив шаблон, вы создаете на его основе несколько файлов, которые наследуют имеющиеся в шаблоне текст и объекты, стили и оформление, макросы и параметры интерфейса Word. Вспомните, что на предыдущих занятиях мы уже пользовались стандартными шаблонами Office, теперь давайте создадим свой собственный шаблон.

  1. Откройте документ, созданный на первом занятии. Удалите из него весь текст, таблицу Excel и рисунок кактуса. На странице останется только надпись Геркулес и горизонтальная линия.

  2. Выберите команду Файл > Сохранить как (File > Save As). Откроется окно диалога Сохранение документа (Save As), показанное на рис. 5.1.

  3. В раскрывающемся списке Тип файла (Save As Type) выберите пункт Шаблон документа (Document Template).

  4. В левой панели окна сохранения файла щелкните на кнопке Мои документы (My Documents).

  5. В панели инструментов щелкните на кнопке Создать папку (Create New Folder).

  6. В открывшемся окне диалога введите текст Шаблоны.

  7. Щелкните на кнопке ОК.

  8. В поле Имя файла (File Name) введите Here.

  9. Щелкните на кнопке Сохранить (Save).

Рис. 5.1. Сохранение шаблона

  10. Выберите команду Файл > Закрыть (File > Close), чтобы закрыть окно шаблона. Теперь у вас есть шаблон с заголовком Геркулес, сохраненный в специальной папке.

  11. Чтобы указать программе Word, где следует искать шаблоны пользователя, выберите команду Сервис > Параметры (Tools > Options).

Рис. 5.2. Пути к служебным файлам

  12. Щелкните в открывшемся окне диалога на вкладке Расположение (File Locations). На этой вкладке, показанной на рис. 5.2, хранится информация об именах, некоторых специальных папок, в том числе и имя папки шаблонов польаователя.

  13. Щелкните на строчке Шаблоны пользователя (User Templates).

  14. Затем щелкните на кнопке Изменить (Modify). Откроется окно диалога, которое очень похоже на окно сохранения файлов, но предназначено для выбора папки.

  15. Щелкните в левой панели этого окна на кнопке Мои документы (My Documents), затем в основной области окна диалога дважды щелкните на недавно созданной папке Шаблоны.

  16. Щелкните на кнопке ОК. Вы вернетесь на вкладку Расположение (File Locations), но теперь в строке Шаблоны пользователя (User Templates) указана правильная папка.

  17. Снова щелкните на кнопке ОК, чтобы закрыть окно параметров.

  18. Теперь попробуйте создать на базе построенного шаблона новый документ. Выберите команду Файл > Создать (File > New). В правой стороне экрана появляется окно Создание документа (New Document) области задач. В разделе Создание с помощью шаблона (New from Template) перечислены недавно используемые шаблоны и ряд стандартных шаблонов. Щелкните на значке Общие шаблоны (General Templates). Значок шаблона Here появился в окне диалога Шаблоны (Templates), как показано на рис. 5.3. Сюда кроме стандартных шаблонов выводятся значки всех файлов с расширением .dot, записанных в папку с шаблонами пользователя.

Рис. 5.3. Выбор шаблона документа

  19. С помощью переключателя Создать (Create New) выберите тип создаваемого 4:>айла. Положение Документ (Document) соответствует созданию обычного текстового документа, а Шаблон (Template) позволяет создать новый шаблон.

  20. Дважды щелкните на значке Here. Откроется новый документ, в котором сразу появится большая надпись Геркулес, как показано на рис. 5.4. Теперь, пользуясь новым шаблоном, вы можете быстро добавлять такие надписи в начало каждого документа гипотетической компании Геркулес, и все они будут точными копиями заголовка, хранящегося в шаблоне.

Рис. 5.4. Документ, построенный на базе шаблона пользователя

Следует заметить, что так называемый «Обычный документ», который создается щелчком на кнопке Создать (New) панели инструментов или выбором значка Новый документ (Blanck Document) в разделе Создание документа (New) окна области задач, на самом деле тоже построен на основе шаблона. Этот шаблон записан в файле Normal.dot, который хранится в папке C:\Microsoft Office\Templates [ Предполагается, что пакет Office 2002 был установлен в папку Microsoft Office диска С:.]. Шаблон NormaLdot играет важную роль. Он определяет исходную конфигурацию Word, т. е. вид и поведение программы при ее запуске.

Примечание

Если вы обнаружили, что Word выглядит как-то странно или работает неверно, попробуйте закрыть программу и удалить файл Normal.dot. При следующем запуске Word этот шаблон будет сгенерирован заново в соответствии со стандартной конфигурацией, заложенной в Word разработчиками программы.


Упражнение 2. Мастер создания документа

Создавая документ с помощью мастера, вы имеете дело как бы с интеллектуальным шаблоном, который может менять свою конфигурацию в соответствии с конкретными запросами пользователя. Мастера часто вставляют в документ специальные макросы — небольшие программы, автоматизирующие ввод текста. На предыдущих занятиях вы уже не раз пользовались мастерами. Давайте детально познакомимся с возможностями этих помощников на примере одного из них — мастера профессионально оформленного резюме.

  1. Выберите команду Файл > Создать (File > New). В окне диалога Создание документа (New Document) области задач в разделе Создание с помощью шаблона (New From Template) щелкните на значке Общие шаблоны (General Templates). В появившемся окне диалога Шаблоны (Templates) раскройте вкладку Другие документы (Other Documents) и дважды щелкните на значке Мастер резюме (Resume Wizard). Откроется первое окно мастера, описывающее назначение запущенного модуля.

Примечание

Обратите внимание, что значки мастеров отличаются от значков обычных шаблонов наличием изображения волшебной палочки.

  2. Щелкните на кнопке Далее (Next).

  3. Во втором окне мастера, показанном на рис. 5.5, установив переключатель в правое положение, выберите для своего резюме изысканный стиль. Затем щелкните на кнопке Далее (Next).

Рис. 5.5. Второе окно мастера резюме

  4. В следующем окне выберите положение переключателя Профессиональное (Professional CV) и снова щелкните на кнопке Далее (Next).

Примечание

В нижней части окна любого мастера Office XP есть пять кнопок. Две из них — Далее (Next) и Назад (Back) позволяют перемещаться по окнам мастера. Если вы ошиблись или решили поменять данные, введенные ранее, щелкая на кнопке Назад (Back), вернитесь к одному из предыдущих окон и скорректируйте параметры мастера. При этом нет нужды заново повторять всю процедуру. Кнопка Отмена (Cancel) позволяет в любой момент прервать работу мастера. Кнопка Готово (Finish) инициирует генерацию результата на базе уже введенных данных. Наконец, кнопка с вопросительным знаком позволяет получить справку.

  5. В двух следующих окнах введите свое имя, адрес, телефоны и укажите, какую информацию о вас следует включать в резюме.

  6. В шестом окне мастера, показанном на рис. 5.6, установите флажки, соответствующие тем разделам, которые должны быть включены в резюме.

Рис. 5.6. Шестое окно мастера резюме

  7. Щелкните на кнопке Далее (Next).

  8. В следующем окне укажите, какие дополнительные разделы следует включать в документ, а с помощью последнего из информативных окон добавьте при необходимости разделы, не предусмотренные разработчиками мастера. Щелкните на кнопке Далее (Next).

  9. В последнем окне мастера, информирующем о том, что все готово для создания документа, щелкните на кнопке Готово (Finish). Мастер сгенерирует документ, показанный на рис. 5.7. В нем появятся введенные вами данные и дополнительные поля, которые можно заполнить позже.
  10. Сохраните это резюме в папке Мои документы (My Documents) под именем Резюме. Теперь вы умеете строить документы на базе шаблонов и наполнять их информацией с помощью мастеров. Однако иногда случается так, что текстовое содержание уже имеется в обычном текстовом файле ASCII, например, полученном по электронной почте. Такой текст легко импортируется в Word, где его можно оформить с помощью мощных возможностей этого текстового редактора. Чтобы открыть ASCII-текст формата DOS, выполните следующие шаги.
  11. Выберите команду Файл > Открыть (File > Open).
  12. В раскрывающемся списке Тип файлов (Files Of Types) окна диалога Открытие документа (Open) выберите пункт Текстовые файлы (Text Files) или Все файлы (All Files).

Рис. 5.7. Документ, сгенерированный мастером

  13. Найдите текстовый файл и дважды щелкните на его значке. Откроется окно диалога Преобразование файла (Convert File), показанное на рис. 5.8.

Рис. 5.8. Выбор варианта преобразования

  14. Выберите пункт Текст MS-DOS (MS-DOS Text).

Примечание

Если окно преобразования не появится, вы не сможете правильно настроить отображение русских букв. В этом случае выберите команду Сервис > Параметры (Tools > Options) и на вкладке Общие (General) установите флажок Подтверждать преобразование при открытии (Confirm Conversion At Open). Затем повторите импорт текстового файла.

  15. Щелкните на кнопке ОК. Текст DOS будет преобразован в формат Windows. При импорте файлов другого формата выбирайте в окне диалога Преобразование файла (Convert File) нужный вариант преобразования.


Режимы просмотра

В Microsoft Word один и тот же документ можно отображать в четырех перечисленных ниже режимах просмотра.

  • Обычный (Normal View) — предназначен для ввода и форматирования текста, отображаемого в виде непрерывной вертикальной полосы.

  • Разметка страницы (Print Layout View) — позволяет оценить расположение текста и объектов относительно физических страниц документа.

  • Структура (Outline View) — служит для задания и редактирования иерархической структуры разделов основного текста, что позволяет полностью отвлечься от графических объектов и реальных размеров страниц и сконцентрировать внимание на содержании.

  • Веб-документ (Web Layout View) — предназначен для формирования web-страниц, для которых характерна неограниченная длина.

Режимы просмотра проще всего переключать с помощью кнопок, расположенных в левом нижнем углу окна документа (рис. 5.9). Не забывайте про наличие разных режимов, всегда работайте в том из них, который лучше соответствует решаемой задаче.

Рис. 5.9. Кнопки режимов просмотра


Упражнение 3. Обычный режим

Создавая или модифицируя текстовый документ, вы чаще всего работаете в обычном режиме просмотра. На рис. 5.10 показан пример документа в этом режиме и основные элементы окна Word. При обычном просмотре документ имеет неограниченную длину, хотя его ширина определяется размером страницы. Разбиение на страницы показано горизонтальными пунктирными линиями. В этом режиме на экране не видны фигуры, рисунки и другие графические объекты.

Рис. 5.10. Документ Word в обычном режиме

Строка состояния Word в любом режиме просмотра выводит одну и ту же информацию, которая помогает ориентироваться в больших документах. В первом слева поле строки состояния видны номер текущей страницы, номер текущего раздела, а далее через дробь — номер текущей страницы и число страниц в документе. Во второе поле выводится расстояние от левого края документа до текущего положения текстового курсора, затем номера текущих строки и столбца.

  1. Откройте любой не очень короткий документ и с помощью команды Вид > Обычный (View > Normal) включите обычный режим просмотра (если текущим является другой режим).

  2. Щелкните на кнопке Схема документа (Document Map). В левой части окна появится панель, демонстрирующая иерархическую структуру разделов документа, как показано на рис. 5.11. Указанная кнопка играет роль флажка. Повторный щелчок на ней скроет панель схемы. Такую панель можно открыть и в любом другом режиме просмотра.

  3. Щелкните в панели схемы документа на одном из пунктов. Текст в основном окне переместится к соответствующему разделу.

Примечание

Раздел характеризуется наличием заголовка, отмеченного специальным стилем. Вы познакомитесь с этими стилями в упражнении 5 этого занятия.

Рис. 5.11. Схема документа

  4. Чтобы прокрутить текст вручную, пользуйтесь кнопками и ползунком вертикальной полосы прокрутки, расположенной в правой части окна. Полоса прокрутки есть и в панели схемы документа.

  5. Щелкните на кнопке Следующая страница (Next Page). Текст в окне переместится к началу следующей страницы. Кнопка Предыдущая страница (Previous Page) выполняет обратную процедуру, прокручивая текст на одну страницу вверх.

  6. Щелкните на кнопке Выбор объекта перехода (Select Browse Object). Откроется показанное на рис. 5.12 окно со значками. Эти значки позволяют изменять функции кнопок Следующая страница (Next Page) и Предыдущая страница (Previous Page).

Рис. 5.12. Выбор объекта перехода

  7. Попробуйте щелкнуть на значке Разделы (Browse By Section). Теперь указанные кнопки будут прокручивать документ соответственно к предыдущему и следующему разделу (а не к странице).

  8. В обычном режиме в верхней части окна может располагаться горизонтальная линейка, позволяющая контролировать горизонтальные отступы. Чтобы показать или скрыть линейку, выберите команду Вид > Линейка (View > Ruler).

  9. Вероятно, вы захотите настроить масштаб отображения текста по своему вкусу. Для этого щелкните на раскрывающемся списке Масштаб (Zoom) панели инструментов Стандартная (Standard) и выберите подходящий масштаб. Чтобы ширина текста в точности равнялась ширине окна, выберите последний пункт По ширине страницы (Page Width).

  10. Выполните команду Вид > Во весь экран (View > Full Screen). Окно Word развернется на весь экран компьютера. При этом исчезнут меню, заголовок окна, панели инструментов, строка состояния и полоса прокрутки. Будет виден только сам документ и кнопка Вернуть обычный режим (Close Full Screen). Такой полноэкранный режим просмотра позволяет целиком сосредоточиться на содержании документа.

  11. Чтобы вернуть исчезнувшие элементы интерфейса, щелкните на кнопке Вернуть обычный режим (Close Full Screen).

Примечание

В полноэкранном режиме можно пользоваться всеми командами меню. Переместите указатель мыши вплотную к верхнему краю экрана, и перед вами появится всплывающая строка меню Word.

  12. Дважды щелкните в любом из двух левых полей строки состояния. Откроется окно перехода к объекту, показанное на рис. 5.13.
  13. В списке Объект перехода (Go To What) выберите тип объекта, который нужно найти, например пункт Страница (Page).

Рис. 5.13. Вкладка перехода окна диалога поиска и замены

  14. В поле Введите номер страницы (Enter Page Number), название которого варьируется в зависимости от выбранного типа объекта, введите номер страницы, к которой нужно перейти. Для перехода вперед или назад на N страниц относительно текущей введите соответственно +N или -N, где N — целое число.
  15. Щелкните на кнопке Перейти (Go To). Документ прокрутится до искомого объекта.


Упражнение 4. Разметка страницы

Режим разметки страниц позволяет видеть документ таким, каким он будет на бумажных страницах, распечатанных на принтере. Здесь в виде белых прямоугольников отображаются страницы документа, на которых наряду с текстом видны абсолютно все объекты, как показано на рис. 5.14. Если документ содержит многочисленные рисунки или графики, с ним удобнее работать именно в режиме разметки страницы.

Рис. 5.14. Режим разметки страницы

Окно режима разметки практически не отличается от окна обычного режима. Но включив отображение линейки, вы кроме горизонтальной линейки увидите еще и вертикальную, которая позволяет оценивать положение объектов на странице по второй координате. Приемы перемещения по документу тоже совпадают в обоих режимах, однако в раскрывающемся списке Масштаб (Zoom) в режиме разметки появляются три дополнительных пункта —По ширине текста (Text Width), Страница целиком (Whole Page) и Две страницы (Two Pages), названия которых не требуют дополнительных пояснений.

Работая в режиме разметки, не спешите расставлять объекты и форматировать текст. Для начала следует настроить размеры страницы и ее полей.

  1. Выберите команду Файл > Параметры страницы (File > Page Setup).

  2. В открывшемся окне диалога щелкните на вкладке Размер бумаги (Paper Size), которая показана на рис. 5.15.

  3. В списке Размер бумаги (Paper Size) выберите тот размер листа, на котором должен печататься документ.

  4. Чтобы задать нестандартный размер, выберите пункт Другой (Custom Size) и введите ширину и высоту страницы в счетчики Ширина (Width) и Высота (Height).

Рис. 5.15. Параметры страницы

  5. После настройки размеров страницы следует указать размеры отступов и выбрать вариант вывода текста на принтер. Для этого раскройте вкладку Поля (Margins), которая показана на рис. 5.16.

  6. В счетчики Верхнее (Тор), Нижнее (Bottom), Левое (Left) и Правое (Right) введите ширину полей страницы.

  7. С помощью переключателя Ориентация (Orientation) окна диалога параметров страницы выберите книжное или альбомное расположение страницы относительно текста.

Рис. 5.16. Настройка полей

  8. Если вы собираетесь печатать документ на обеих сторонах листов, а левый и правый отступы не равны между собой, то в раскрывающемся списке Несколько страниц: (Multiple Pages) выберите Зеркальные поля (Mirror Margins). Это обеспечит правильную расстановку полей. При выборе 2 страницы на листе (2 Pages Per Sheet) на одном листе бумаги будут размещены две страницы. Поле Образец (Preview) отображает текущую раскладку страниц и позволяет визуально проконтролировать введенные параметры.

Примечание

В верхнем и нижнем поле страницы расположены верхний и нижний колонтитулы, в которых размещаются, например, номера страниц или названия текущих разделов документа. Если вы пользуетесь колонтитулами, не делайте верхнее и нижнее поля слишком узкими.

  9. Раскройте вкладку Источник бумаги. В разделе Различать колонтитулы: с помощью соответствующих счетчиков настройте расстояния от края страницы до верхнего и нижнего колонтитулов.
  10. Щелчком на кнопке О К закройте окно диалога параметров страницы.
  11. Поля можно настроить и с помощью линеек. Чтобы увеличить ширину левого поля, поместите указатель мыши на границу серой и белой областей горизонтальной линейки (см. рис. 5.14), нажмите кнопку мыши и перетаскивайте границу поля. Аналогично настраиваются и остальные три поля страницы.
  12. В многостраничном документе, как правило, требуется расстановка номеров страниц. Нет смысла делать это вручную. Word умеет нумеровать страницы автоматически. Выберите команду Вставка > Номера страниц (Insert > Page Numbers). Откроется окно диалога, показанное на рис. 5.17.

Рис. 5.17. Добавление нумерации страниц

  13. С помощью раскрывающегося списка Положение (Position) укажите, должны ли номера страниц располагаться вверху или внизу страницы. В списке Выравнивание (Alignment) выберите нужный режим выравнивания номера в колонтитуле.

  14. Чтобы номер отсутствовал на первой странице документа, сбросьте флажок Номер на первой странице (Show Number On First Page).

  15. Если требуется дополнительное форматирование номеров, щелкните на кнопке Формат (Format) и настройте параметры окна диалога Формат номера (Page Number Format).

  16. Щелчками на кнопках OK закройте все окна диалога. Word автоматически пронумерует страницы документа. При редактировании текста вы сможете выбрасывать и вставлять фрагменты, а также перемещать целые блоки страниц. Word автоматически скорректирует нумерацию и обеспечит правильную последовательность чисел.

  17. Чтобы изменить шрифт номеров страниц и добавить в колонтитулы другую информацию, выберите команду Вид > Колонтитулы (View > Header And Footer). Текст документа станет блеклым, а колонтитулы будут выделены пунктирными прямоугольниками, как показано на рис. 5.18. Кроме того, появится панель инструментов Колонтитулы (Header And Footer).

  18. С помощью полосы прокрутки найдите любой прямоугольник с надписью Верхний колонтитул (Header).

  19. Введите в нем текст Это верхний колонтитул. Теперь в верхнем поле каждой страницы будет выведена такая надпись. Вы скажете, что-подобные заголовки страниц никому не нужны. Да, конечно, это лишь простейший пример. Давайте посмотрим, какие возможности предлагает панель инструментов Колонтитулы (Header And Footer).

Рис. 5.18. Редактирование колонтитулов

  20. Щелкните в прямоугольнике Нижний колонтитул (Footer).

  21. В панели Колонтитулы (Header And Footer) щелкните на кнопке Вставить авто текст (Insert AutoText).

  22. Выберите в раскрывающемся меню пункт Полное имя файла (Filename And Path). Теперь вы не забудете, как называется файл, в котором хранится источник распечатанного текста. Имя этого файла появится в нижнем колонтитуле каждой страницы. Если вы переименуете файл документа или переместите его в другую папку, то при следующем открытии документа в нижнем колонтитуле появится уже новое имя файла. Панель инструментов Колонтитулы (Header And Footer) позволяет-таюке вставлять в колонтитулы дату и время последнего обновления документа, дату печати документа, имя автора и другую информацию.

  23. Чтобы закрыть режим просмотра колонтитулов, щелкните на кнопке Закрыть (Close) панели инструментов Колонтитулы (Header And Footer). Иногда, просмотрев документ в режиме разметки страницы, вы можете остаться недовольны тем, как Word разбил текст на страницы. В этом случае вручную вставьте в текст дополнительные разрывы страниц.

  24. Поместите курсор в ту точку, где должна начинаться новая страница, и выберите команду Вставка > Разрыв (Insert > Break). Откроется окно диалога, показанное на рис. 5.19. В нем верхний переключатель позволяет из трех положений выбрать тип разрыва. Нижний переключатель позволяет вставить метку начала следующего раздела и выбрать, как должен располагаться раздел: с начала следующей страницы, с четной, с нечетной или без разрыва страницы.

Рис. 5.19. Вставка разрыва

  25. Выберите положение переключателя Новую страницу (Page Break).

  26. Затем щелкните на кнопке ОК. Текст правее и ниже курсора будет перенесен в начало следующей страницы, а конец текущей страницы останется пустым.

Режим электронного документа, который включается командой Вид > Веб-документ (View > Web Layout), является как бы комбинацией обычного режима и режима разметки страницы. Электронный документ позволяет видеть все объекты, включая рисунки и графики, перемещать их по документу и изменять их размер. Но в режиме электронного документа нет разбивки на страницы и весь текст отображается в виде бесконечной вертикальной ленты. Здесь нет и вертикальной линейки. Поскольку предполагается, что электронный документ будет публиковаться на web-узле, разработчики Word учли, что web-страницы могут иметь любую длину, а для их просмотра в окне браузера используется вертикальная полоса прокрутки.

Если вы пользуетесь текстовым процессором Word для подготовки web-страниц, вместо режима разметки страниц всегда пользуйтесь режимом электронного документа. В этом случае после преобразования в формат HTML не произойдет потери назначенного форматирования. Например, на web-странице невозможно разместить текст в несколько столбцов (если не пользоваться таблицами), поэтому режим просмотра электронного документа игнорирует такое форматирование, четко следуя стандартам HTML.

Примечание

Запись формата HTML в Office XP выполняется без ошибок, а полученная web-страница точно повторяет вид исходного электронного документа.

Чтобы сформировать web-страницу, достаточно выбрать команду Файл >Сохранить как веб-страницу (File > Save As Web Page) и в окне диалога Сохранение документа (Save As) ввести имя HTML-файла. Полученную web-страницу можно продолжать модифицировать как в Word, так и в любом web-редакторе.

Примечание

Обратите внимание, что после преобразования в web-страницу или после открытия файла формата HTML в меню Вид (View) появляется новая команда Источник HTML (HTML Source), выбор которой открывает окно с исходным HTML-кодом, формирующим редактируемый документ.


Упражнение 5. Структура документа

Любой достаточно объемный документ обычно состоит из разделов и подразделов разного уровня. Самые внешние разделы, например части той книги, которую вы сейчас читаете, выделяются крупными заголовками. Для занятий выбраны заголовки поменьше. Названия упражнений набраны еще более мелким шрифтом. Такое разбиение документа на отдельные блоки не чуждо и для Word. Этот текстовый процессор позволяет присваивать названиям тех или иных разделов специальные заголовочные стили, которые, во-первых, обеспечивают одинаковое оформление всех заголовков определенного уровня, а во-вторых, дают знать программе Word, где начинается и заканчивается очередной раздел. Эта информация позволяет Word правильно форматировать документ. Например, заголовок раздела никогда не окажется па другой странице, отдельно от текста этого раздела.

Если вы редактируете большой документ, имеющий иерархическую совокупность вложенных друг в друга разделов, с ним удобно работать в режиме структуры. В этом режиме просмотра, показанном на рис. 5.20, удобно переставлять, удалять и добавлять разделы, изменять их уровень.

  1. Щелчком на кнопке Создать (New) откройте новый документ.

  2. С помощью команды Вид > Структура (View > Outline) переключитесь в режим структуры.

  3. Введите текст Параметры оборудования. Нажмите клавишу Enter. Затем введите строку Специальные вопросы, снова нажмите Enter и введите Разрешение проблем. Это будут названия трех разделов верхнего уровня. Им соответствует стиль Заголовок! (Headingi).

  4. Переместите курсор в конец первой строки и нажмите клавишу Enter. Появится еще один заголовок раздела. Чтобы понизить его уровень, нажмите клавишу Tab. Новая строка станет подразделом темы Параметры оборудования (см.рис. 5.20). Введите текст Быстродействие.

  5. Нажмите клавишу Enter и введите заголовок еще одного раздела второго уровня. Обратите внимание, что теперь не нужно нажимать клавишу Tab. В режиме структуры стиль нового абзаца всегда повторяет заголовочный стиль предыдущего абзаца.

  6. Введите еще несколько заголовков разделов второго и третьего уровней, чтобы получить текст, показанный на рис. 5.20. Для понижения уровня от второго к третьему нажимайте клавишу Tab. Имейте в виду, что заголовкам без отступа соответствует стиль Заголовок! (Heading!), заголовкам с одинарным отступом — стиль Заголовок2 (Heading2), а заголовкам с двойным отступом — стиль Заголовок З (Heading3). Следите за полем Стиль (Style) панели инструментов Форматирование (Formatting).

Рис. 5.20. Документ в режиме структуры

В нем всегда указано название стиля того абзаца, в котором находится текстовый курсор. Если вы ошиблись и заголовок получил неверный стиль, не огорчайтесь. Чтобы понизить уровень заголовка, щелкните на нем мышью и нажмите Tab. Для повышения уровня заголовка следует нажать клавиши Shift+Tab. Слева от каждого заголовка имеется знак «плюс» или «минус». «Плюс» говорит о том, что данный раздел не пуст и наполнен определенным содержанием (в данном случае заголовками вложенных подразделов). Пустым разделам соответствует знак «минус».

Примечание

Чтобы узнать стиль абзаца, щелкните в нем и взгляните на список Стиль (Style) панели инструментов Форматирование (Formatting). Абзацные стили используются в Word не только для выделения заголовков. Любому абзацу можно назначить стандартный или специально разработанный для него стиль. Способы форматирования документа с помощью стилей будут рассмотрены на следующем занятии.

Рис. 5.21. Тот же документ в обычном режиме просмотра

  7. Щелчком на кнопке Обычный режим (Normal) переключитесь в обычный режим просмотра. Вы увидите введенные заголовки разделов расположенными друг под другом без отступов. Они будут отличаться шрифтом. Каждому заголовочному стилю соответствует свой шрифт, как показано на рис. 5.21.

  8. Теперь наполните созданные разделы каким-либо содержанием. Для этого щелкайте в конце названия каждого раздела, нажимайте клавишу Enter и вводите текст. Пусть каждый раздел состоит всего из нескольких слов. Сейчас важна не общая длина документа, а его иерархическая структура. Обратите внимание, что в обычном режиме при нажатии клавиши Enter формируется абзац не заголовочного стиля, а стиля Обычный (Normal), который соответствует простому тексту.

  9. Переключитесь обратно в режим Структура (Outline). Вы увидите весь текст документа.

  10. В панели инструментов Структура (Оutlining), которая появляется при переключении в режим структуры, выберите в раскрывающемся списке пункт Показать уровень 2 (Show Level 2). Содержимое документа свернется, и на экране останутся только заголовки первого и второго уровней. Кнопки панели Структура (Outlining), показанной на рис. 5.22, позволяют развернуть документ до разделов любого уровня вложения. Выбор в раскрывающемся списке пункта Показать все уровни (Show All Levels) выводит на экран весь документ. Кнопки со знаками «плюс» и «минус» той же панели разворачивают и сворачивают тот раздел, в котором находится текстовый курсор.

  11. Щелкните в строке заголовка Установка.

  12. Затем щелкните на кнопке Вниз (Move Down) панели инструментов Структура (Outlining). Заголовок Установка сместится вниз под заголовок Обновление.

Рис. 5.22. Панель инструментов режима структуры

  13. Теперь в раскрывающемся списке выберите пункт Показать все уровни (Show All Levels), чтобы снова вывести на экран все содержимое документа. Выполненное перемещение строки заголовка повлекло сдвиг всего раздела.

  14. Щелкните назнаке «плюс» слева от заголовка раздела Быстродействие. Окажутся выделенными этот раздел и все его подразделы, как показано на рис. 5.23.

Рис. 5.23. Выделение раздела документа

  15. Нажатием клавиш Ctrl+Х вырежьте выделенный фрагмент. Переместите текстовый курсор в начало заголовка Обновление и щелкните на кнопке Вставить (Paste) панели инструментов Стандартная (Standard). Выделенный ранее подраздел будет целиком перенесен внутрь раздела Специальные вопросы.


Контрольное упражнение

Пришло время проверить, насколько хорошо вы усвоили материал этого занятия.

  1. Создайте новый шаблон на основе шаблона Here.dot.

    • Как в окне диалога создания документа вывести список шаблонов в виде таблицы с дополнительной информацией о файлах?

  2. Переключитесь в режим структуры и введите несколько заголовков первого уровня, которые соответствуют стандартным разделам шаблона, предназначенного, например, для оформления ежемесячных отчетов отделов компании.

    • Подумайте, как с помощью панели инструментов Структура (Outlining) убрать оформление заголовков разделов и вместить в окно больше текста?

  3. Переключитесь в обычный режим и введите в разделы шаблона пояснительный текст, указывающий на то, какая информация должна размещаться в каждом разделе.

  4. В режиме разметки страниц добавьте нумерацию страниц. Установите ширину левого поля страницы 4 см, а правого — 3 см.

    • Для переплета отчетов необходимо добавить в верхней части страницы дополнительное поле в 2 см. Как это сделать?

  5. Распечатайте новый шаблон и сохраните его в папке Мои документы (My Documents).


Подведение итогов

Теперь вы умеете создавать сложные текстовые документы с помощью шаблонов и мастеров Word, а также разрабатывать собственные шаблоны. Вы можете редактировать документ в одном из четырех режимов просмотра, разрабатывать общую структуру документа, настраивать параметры страницы и перемещаться по тексту с помощью панели схемы документа.

После создания структуры документа и ввода текста следует побеспокоиться о внешнем виде текста. Конечно, главным является смысловое наполнение документа, но грамотное форматирование и выделение ключевых фраз облегчает чтение и способствует пониманию смысла написанного. Следующее занятие посвящено вопросам форматирования текста.


Занятие №2

Оформление документа

ТЕМА ЗАНЯТИЯ

На занятии рассказывается об инструментах Word, позволяющих форматировать текст и придавать документу необходимое оформление. Вы познакомитесь с операциями и элементами форматирования, которые перечислены ниже:

  • настройка отступов и интервалов;

  • табуляция;

  • маркированные и нумерованные списки;

  • текст в несколько столбцов;

  • выбор начертания и размера шрифта;

  • стиль;

  • линии и фигуры;

  • библиотека ClipArt.


Параметры абзаца

Простейшие текстовые редакторы, подобные Блокнот (Notepad) или встроенному редактору командной оболочки Norton Commander, не отслеживают смысловую логику документа. В них основной структурной единицей является символ. В текстовых процессорах, к которым относится и Word, в качестве элементарного структурного блока рассматривается абзац. Word полагает, что содержимое абзаца является связным текстом, и сам расставляет буквы и слова внутри абзаца наилучшим образом в соответствии с назначенными пользователем правилами форматирования. В результате в процессе редактирования документа отпадает необходимость в корректировке длины строк, выделении заголовков специальным шрифтом, добавлении маркеров списков и отступов «красной строки». Word сам позаботится о правильном оформлении. Вам нужно лишь указать программе правила, в соответствии с которыми должен форматироваться документ.


Упражнение 1. Отступы, интервалы и табуляции

Конфигурация абзаца характеризуется отступами сверху и снизу, интервалами слева и справа, межстрочным интервалом, отступом первой строки, режимом выравнивания текста по ширине страницы и некоторыми другими параметрами. Давайте изучим приемы настройки этих величин.

  1. Запустите Word и в автоматически открывшемся новом документе напечатайте несколько десятков слов, например введите текст любого абзаца этой книги. Обратите внимание, что по достижении правого края страницы текст автоматически переносится на следующую строку.

  2. Окончив ввод абзаца, нажмите клавишу Enter. Текстовый курсор переместится на новую строку, обозначив этим конец текущего абзаца и подготовив текстовый процессор для ввода следующего.

  3. Введите еще несколько абзацев.

  4. Щелчком на кнопке Режим разметки (Print Layout View) переключитесь в режим разметки страниц, который позволяет видеть точное форматирование текста. (На протяжении всего занятия используйте именно этот режим просмотра документа.)

  5. Если на экране нет вертикальной и горизонтальной линеек, включите их командой Вид > Линейка (View > Ruler). Теперь окно Word будет выглядеть примерно так, как показано на рис. 6.1. Чтобы задать расстояния от границ левого и правого полей страницы до абзацев некоторого блока текста, нужно настроить отступы блока. При изменении ширины полей страницы размеры абзацев модифицируются таким образом, чтобы отступы от краев полей оставались неизменными. Для настройки отступов блока текста нужно сначала выделить этот текст. Если требуется модифицировать параметры только одного абзаца, достаточно просто поместить в него текстовый курсор.

  6. Выделите второй и третий абзацы.

Рис. 6.1. Пять абзацев и линейки в режиме разметки страниц

  7. В левой части горизонтальной линейки найдите треугольный маркер Отступ первой строки (First Line Indent), вершина которого направлена вниз, захватите его мышью и перетащите вправо на 3 см. Перемещением этого маркера можно изменять положение начала первых строк выделенных абзацев, не изменяя отступов остального текста. Заметьте, что первая строка может начинаться как правее (отступ), так и левее (выступ) основного текста.

  8. Перетащите вправо на 1 см маркер Выступ (Hanging Indent), имеющий форму треугольника, вершина которого направлена вверх. Изменится левый отступ тела абзацев, но отступ первых строк останется прежним.

  9. В левой части горизонтальной линейки есть еще один маркер, имеющий форму прямоугольника, — Отступ слева (Left Indent). Перетащите его вправо на 1 см. Вы увидите, что перемещение этого маркера равносильно синхронному сдвигу маркеров Отступ первой строки (Line Indent) и Выступ (Hanging Indent) на одинаковое расстояние, то есть приводит к смещению левого края абзаца относительно поля страницы.

  10. Щелкните на тексте второго абзаца, сняв выделение блока текста и поместив курсор в тело этого абзаца.

  11. Перетащите влево на 4 см маркер Отступ справа (Right Indent), расположенный в правой части горизонтальной линейки. Он задает правый край абзаца.

После всех проделанных операций текст выглядит так, как показано на рис. 6.2.

Рис. 6.2. Настройка отступов

  12. Щелкните на кнопке По центру (Center) панели инструментов Форматирование (Formatting).

Рис. 6.3. Режимы выравнивания

Рис. 6.4. Окно диалога параметров абзаца

  13. Выделите третий абзац и щелкните на кнопке По правому краю (Align Right) той же панели инструментов.

  14. Щелкните на четвертом абзаце, а затем на кнопке По ширине (Justify). Теперь первые четыре абзаца текста демонстрируют четыре режима выравнивания текста (рис. 6.3).

  15. Выделите второй, третий и четвертый абзацы и выберите команду Формат > Абзац (Format > Paragraph). Вкладка Отступы и интервалы (Indents And Spacing) открывшегося окна диалога (рис. 6.4) позволяет задавать отступы абзаца и режим выравнивания, которые мы настраивали с помощью горизонтальной линейки и кнопок панели инструментов Форматирование (Formatting). Раздел Интервал (Spacing) той же вкладки позволяет задать интервал между строками внутри абзаца и расстояние между абзацами.

Рис. 6.5. Настройка интервалов

  16. Введите в счетчик перед (Before) число 6.

  17. В списке междустрочный (Line Spacing) выберите пункт Полуторный (1,5 tines).

  18. Щелкните на кнопке ОК. Интервалы в трех выделенных абзацах изменятся и станут такими, как показано на рис. 6.5. Обратите внимание, что область Образец (Preview) окна диалога Абзац (Paragraph) позволяет наблюдать влияние введенных величин па вид текущего абзаца еще до окончательного применения выбранных значений параметров к тексту документа.

  19. Сохраните документ, он пригодится вам в следующих упражнениях.


Упражнение 2. Списки и столбцы

Word позволяет последовательно нумеровать абзацы или выделять их с помощью разнообразных маркеров, размещаемых слева от первых строк абзацев. Для изучения маркированных и нумерованных списков воспользуйтесь текстом документа, созданным в предыдущем упражнении.

  1. Нажатием клавиш Ctrl+A выделите весь текст.

  2. Чтобы вернуть всем абзацам оформление, свойственное стилю Обычный (Normal), выберите соответствующий пункт в раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting).

  3. Щелкните на кнопке Нумерация (Numbering) той же панели инструментов. Абзацы будут пронумерованы последовательными числами.

  4. Поместите курсор в конец второго абзаца и нажмите клавишу Enter. Новому абзацу автоматически будет присвоен номер 3, а номера последующих абзацев изменятся так, чтобы сохранилась непрерывная последовательность чисел.

Рис. 6.6. Списки

  5. Выделите второй абзац, затем щелкните на кнопке Маркеры (Bullets) панели инструментов Форматирование (Formatting). Номер выделенного абзаца заменится на маркер. Заметьте, что при этом остальные абзацы снова будут перенумерованы (рис. 6.6).

  6. Word предлагает пользователям разнообразные типы нумерации и значки маркеров. Чтобы оформить фрагмент текста по своему вкусу, выделите его и выполните команду Формат > Список (Format > Bullets And Numbering). Вкладка Маркированный (Bulleted) открывшегося окна диалога Список (Bullets And Numbering) позволяет выбрать для выделенных абзацев форму маркеров (рис. 6,7). Для этого достаточно щелкнуть на прямоугольнике с маркером нужного типа, а затем на кнопке ОК. Вкладка Нумерованный (Numbered) того же окна диалога дает возможность указать тип нумерации. Эта вкладка практически идентична предыдущей, что указывает на родственную природу маркированных и нумерованных списков.

Рис. 6.7. Выбор маркера

Примечание

Чтобы убрать маркеры и нумерацию, выберите в окне диалога Список (Bullets And Numbering) прямоугольник Нет (None).

В некоторых случаях текст документа необходимо разместить в несколько столбцов. Чтобы преобразовать в такую форму готовый текст, выполните следующие действия.

  7. Выделите первый и второй абзацы рабочего примера и щелкните на кнопке Колонки (Columns) панели инструментов Стандартная (Standard). В раскрывшейся палитре щелкните на третьем столбце. Теперь текст первых двух абзацев будет разбит на три столбца, как показано на рис. 6.8.

    Обратите внимание, что с помощью горизонтальной линейки можно по отдельности настраивать отступы каждого столбца (для этого нужно выделить соответствующий фрагмент текста) и интервалы между столбцами.

  8. Чтобы изменить параметры столбцов, переместите курсор в текст одного из них и выполните команду Формат > Колонки (Format > Columns). В открывшемся окне диалога можно выбрать одну из пяти стандартных конфигураций столбцов, задать число столбцов, их ширину и расстояние между ними.

Рис. 6.8. Текст в три столбца

Примечание

Столбцы видны в документе только в режиме разметки страницы. Во всех остальных режимах просмотра текст выводится в один столбец, хотя параметры столбцов при этом не сбрасываются и учитываются при печати такого документа в любом режиме просмотра.


Форматирование текста

Возможности оформления не ограничиваются параметрами абзацев. Word позволяет изменять размер, начертание, цвет и другие характеристики шрифта, которым набран текст документа. Для облегчения ввода текста и представления табличных данных можно воспользоваться табулированными отступами. Чтобы задать однотипное оформление нескольким абзацам одного или разных документов, можно настроить абзацные стили пользователя.


Упражнение 3. Выбор шрифта

Программа Word позволяет настраивать различные параметры символов. В этом упражнении мы коснемся лишь некоторых. Давайте рассмотрим кнопки панели инструментов, позволяющие быстро изменять начертание шрифта.

  1. Чтобы отформатировать символы фрагмента текста, выделите его, а затем щелкните на одной из кнопок панели инструментов Форматирование (Formatting), перечисленных в табл. 6.1.

ТАБЛИЦА 6.1. Раскрывающиеся списки и кнопки форматирования символов
Кнопка или список | Клавиатурная комбинация | Назначение
Bold (Полужирный) | Ctrl+B | Выделяет полужирным начертанием
Italic (Курсив) | Ctrl+I | Выделяет курсивом
Underline (Подчеркнутый) | Ctrl+U | Подчеркивает текст
Font Size (Размер шрифта) |  | Позволяет выбрать или ввести размер шрифта
Font (Шрифт) |  | Позволяет выбрать один из шрифтов, установленных в Windows
Font Color (Цвет шрифта) |  | Щелчок на кнопке выделяет текст ранее выбранным цветом. Щелчок на стрелке справа от кнопки раскрывает палитру цветов, с помощью которой задается цвет текста
Highlight (Выделение цветом) |  | Щелчок на кнопке окрашивает фон текста ранее выбранным цветом. Щелчок на стрелке справа от кнопки раскрывает палитру цветов, с по мощью которой задается цвет фона
Superscript (Верхний индекс) | Ctrl+Shift+= | Преобразует выделенный текст в верхний индекс
Subscript (Нижний индекс) | Ctrl+O | Преобразует выделенный текст в нижний индекс

На рис. 6.9 показан пример текста, разные фрагменты которого выделены тем или иным способом форматирования.

Рис. 6.9. Варианты форматирования текста

Примечание

Две последние кнопки из перечисленных в табл. 6.1 в стандартной конфигурации Word отсутствуют на панели инструментов. Чтобы они там появились, щелкните на треугольнике, расположенном в правой части панели инструментов, выберите команду Добавить или удалить кнопки (Add Or Remove Buttons) и щелкните в раскрывшемся списке кнопок на соответствующих названиях.

Рис. 6.10. Выбор формата шрифта

  2. Для получения доступа к дополнительным параметрам шрифта выберите команду Формат > Шрифт (Format > Font). Откроется окно диалога Шрифт (Font). Одноименная вкладка, показанная на рис. 6.10, позволяет выбрать шрифт, его размер, вариант начертания, режим и цвет подчеркивания. Здесь же есть несколько флажков, позволяющих включать и отключать режимы оформления.

Примечание

Если изменить форматирование текста, не выделив предварительно никакого фрагмента, то новый формат будет назначен тексту, вводимому в точке текстового курсора. Однако любое перемещение курсора до ввода первого символа отменит новую настройку формата.

  3. Две другие вкладки окна диалога Шрифт (Font) дают возможность настраивать интервалы между буквами, смещение символов и кернинг, а также назначать тексту анимационные эффекты.


Упражнение 4. Табуляция

В то время как поля и отступы определяют общий вид документа и абзацев, табуляции помогают размещать текст внутри абзаца. Позиции табуляции задают точки на горизонтальной линейке, по которым можно выравнивать текст. В этом упражнении с помощью табуляций строится небольшая таблица из двух строк.

  1. Создайте новый документ Word.

  2. Щелкните на горизонтальной линейке на отметке 2 см. На линейке появится значок табуляции.

  3. Щелкните на отметках 5,8 и 11 см, чтобы добавить еще три позиции табуляции.

  4. Нажмите клавишу Tab и введите цифру-1. Текстовый курсор перепрыгнет в текущей строке вправо на позицию 2 см, где и появится введенная цифра.

  5. Напечатайте цифры 2, 3 и 4, нажимая перед вводом каждой из них клавишу Tab.

  6. Нажмите клавишу Enter и введите еще четыре числа, предваряя каждое из них нажатием клавиши Tab. В документе появятся два столбца чисел, выравненных по размещенным ранее позициям табуляции, как показано на рис. 6.11.

  7. Выделите две строки с числами и перетащите значок табуляции с отметки 8 см на отметку 7 см. Третий столбец таблицы сместится влево вслед за значком табуляции.

Нажатие клавиши Tab всегда перемещает текстовый курсор к следующей из установленных позиций табуляции, а сдвиг значка табуляции влечет смещение текста, привязанного к этой позиции. Таким образом можно строить небольшие таблички и задавать стандартные отступы. Word предлагает несколько режимов выравнивания текста по позиции табуляции. Чтобы выбрать нужный вариант, щелкайте на прямоугольнике режима табуляции в левой части горизонтальной линейки до тех пор, пока не появится нужный значок. После этого щелчком разместите позицию табуляции на нужной отметке горизонтальной линейки. Значки разных типов табуляции и возможные режимы выравнивания перечислены в табл. 6.2.

Рис. 6.11. Табулированный текст

ТАБЛИЦА 6.2. Типы табуляции

Значок | Назначение режима
 | Левый край текста выравнивается по табуляции
 | Правый край текста выравнивается по табуляции
 | Центр выравнивается по табуляции
 | Десятичная точка числа выравнивается по табуляции
 | Вертикальный отрезок в данной опции
 | Непосредственное размещение отступа первой строки
 | Непосредственное размещение левого отступа тела абзаца

Примечание

Чтобы удалить позицию табуляции, перетащите ее значок на поле режима табуляции.

  8. Не отменяя выделения столбцов, выберите команду Формат > Табуляция (For mat > Tabs). Откроется окно диалога, показанное на рис. 6.12.

  9. В списке Позиции табуляции (Tab Stop Position) щелкните на последней строке.

  10. Щелкните на кнопке Удалить (Clear), чтобы убрать позицию табуляции, расположенную в районе 11 см.

Рис. 6.12. Окно диалога настройки табуляции

  11. В поле ввода Позиции табуляции (Tab Stop Position) введите число 12.

  12. Выберите положение По правому краю (Right) переключателя Выравнивание (Alignment).

  13. Выберите положение 2 переключателя Заполнитель (Leader).

  14. Щелкните на кнопке Установить (Set).

Рис. 6.13. Коррекция четвертой позиции табуляции

  15. Закройте окно щелчком на кнопке ОК. Теперь вместо табуляции в районе 11 см (которая была установлена на глаз) появится табуляция в позиции 12 см с выравниванием текста по правому краю и с заполнением пустого пространства перед табуляцией точками, как показано на рис. 6.13.

Примечание

Счетчик По умолчанию (Default Tab Stops) окна диалога Табуляция (Tabs) задает расстояние между позициями табуляций, присутствующими по умолчанию правее самой правой табуляции, установленной пользователем (см. рис. 6.12), а также по всей ширине документа при отсутствии принудительно настроенных табуляций.


Упражнение 5. Стиль

Стиль — это именованное описание формата абзаца или символов текста. Вместо того чтобы вручную форматировать каждый абзац, можно задать стиль и настроить для него необходимые параметры. Затем таким стилем можно оформить любой блок текста, в результате параметры стиля будут перенесены на конкретный фрагмент документа.

Стили бывают двух типов:

  • абзацный — задает оформление целого абзаца;

  • символьный — задает шрифт, начертание и оформление фрагмента текста абзаца.

Любому символу текста всегда присущи два стиля: абзацный и символьный. По умолчанию Word присваивает тексту абзацный стиль Обычный (Normal) и символьный стиль Основной шрифт абзаца (Default Paragraph Font). Все приемы форматирования текста, рассмотренные выше на этом занятии, не влияли на его стиль. Сейчас давайте сформируем два новых стиля.

  1. Создайте новый документ. Выберите команду Формат > Стили и Форматирование (Format >Styles and Formatting). В правой части экрана в области задач откроется соответствующее окно, показанное на рис. 6.14.

Рис. 6.14. Окно стилей

  2. В разделе Выберите форматирование для применения (Pick Formatting to Apply) перечислен набор доступных стилей. Поставьте указатель мыши на одном из них. Появляется всплывающая подсказка с кратким описанием указанного стиля. Щелкните на выбранном стиле. В разделе Форматирование выделенного текста (Formatting Selected Text) появится название этого стиля и раскрывающийся список, содержащий доступные операции.

Примечание

Благодаря наличию области задач в приложениях Microsoft Office XP работа по созданию, изменению и применению стилей значительно облегчилась.

  3. Щелкните на кнопке Создать стиль (New Style), откроется окно диалога Создание стиля (New Style), показанное на рис. 6.15.

  4. В раскрывающемся списке Стиль (Style Type) оставьте вариант Абзаца (Paragraph), так как сейчас нам нужен стиль для оформления абзаца.

Рис. 6.15. Создание нового стиля

  5. В поле Имя (Name) введите название Красивый абзац.

  6. В списке Основан на стиле (Style Based On) выберите пункт Обычный (Normal). В результате все параметры нового стиля будут соответствовать одноименным параметрам стиля Обычный (Normal), которые мы затем немного изменим.

  7. Щелкните па кнопке Формат (Format) и в раскрывшемся меню выберите пункт Абзац (Paragraph). Откроется стандартное окно форматирования абзаца (см. выше рис. 6.4), с помощью которого в данной ситуации задаются параметры шрифта настраиваемого стиля.

  8. Выберите режим выравнивания По ширине (Justified), введите для отступов абзаца слева и справа значение 1 см, для отступа первой строки — 2 см и для интервала перед абзацем — 6 пунктов. Затем щелкните два раза на кнопке ОК. Новый стиль появится в списке Выберите форматирование для применения (Pick Formatting to Apply) окна диалога Стили и Форматирование(Styles and Formatting).

  9. Снова щелкните на кнопке Создать стиль (New Style).

  10. В раскрывающемся списке Стиль (Style Type) появившегося окна диалога Создание стиля (New Style) выберите пункт Знака (Character), чтобы определить новый символьный стиль.

  11. В поле Имя (Name) введите название Крупный текст.

  12. В списке Основан на стиле (Based On) выберите пункт Основной шрифт абзаца (Default Paragraph Font).

  13. Щелкните на кнопке Формат (Format) и в раскрывшемся меню выберите пункт Шрифт (Font).

Примечание

Меню кнопки формат (Format) открывает доступ к любым параметрам абзаца или шрифта. Самостоятельно изучите остальные команды этого меню.

  14. В открывшемся окне диалога форматирования шрифта (см. рис. 6.11)выбери-те шрифт ArialCyr, размер 20 пунктов, начертание Полужирный курсив (Bold Italic).

  15. Два раза щелкните на кнопке ОК, а затем щелкните на кнопке Close (Закрыть). Теперь документ содержит описания двух новых стилей, с помощью которых можно форматировать абзацы и фрагменты текста.

  16. Введите несколько абзацев текста и выделите первые три.

  17. В раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting) выберите новый стиль Красивый абзац. Три выделенных абзаца окажутся оформленными в соответствии с только что созданным абзацным стилем.

  18. Выделите несколько слов в первом абзаце и выберите в том же списке Стиль (Style) пункт Крупный текст. Выделенные слова изменятся в соответствии с новым символьным стилем.

  19. Повторите эту операцию, выделяя слова второго, третьего и четвертого абзацев (рис. 6.16).

Казалось бы, те же самые операции можно выполнить и с помощью обычных команд форматирования, но оформление текста с помощью стилей дает несколько преимуществ.

  • Стиль способен хранить сложный вариант форматирования, который можно быстро назначить любому абзацу или фрагменту.

  • Стиль можно поместить в шаблон, и его унаследуют все документы, созданные на основе этого шаблона.

  • Изменив стиль, вы моментально измените вид всех фрагментов документа, оформленных в соответствии с этим стилем.

Рис. 6.16. Оформление с помощью стилей

  • Модифицировав стиль в шаблоне, вы сразу же измените вид всех фрагментов текста, отформатированных этим стилем во всех документах, основанных на скорректированном шаблоне. (Чтобы этого добиться, для каждого из выбранных документов в окне диалога Шаблоны и надстройки (Templates And Add-ins), которое открывается командой Сервис > Шаблоны и надстройки (Tools > Templates And Add-ins), должен быть установлен флажок Автоматически обновлять стили (Automatically Update Document Styles)).

  20. Чтобы почувствовать всю мощь шаблонов в действии, снова выберите команду Формат > Стили и Форматирование (Format > Styles and Formatting), в списке Выберите форматирование для применения (Pick Formatting to Apply) выделите пункт Красивый абзац и в раскрывающемся списке выберите команду Изменить (Modify).

  21. В окне диалога Изменение стиля (Modify Style) щелкните на кнопке Формат (Format), а затем выберите в раскрывшемся списке пункт Абзац (Paragraph).

  22. В окне диалога Абзац (Paragraph) увеличьте отступы слева и справа до 2 см. Два раза щелкните на кнопке ОК, а затем щелкните на кнопке Закрыть (Close).

Обратите внимание, что увеличились отступы у трех первых абзацев, которым был назначен стиль Красивый абзац. Аналогичным способом можно быстро скорректировать, например, размер шрифта фрагментов, выделенных стилем Крупный текст. Подумайте, сколько бы времени ушло на такое изменение оформления стандартными средствами, если бы потребовалось модифицировать несколько абзацев, разбросанных по многостраничному документу.

Подготовив специальные стили для определенных элементов текста (например, для подрисуночных подписей), вы сможете настраивать формат всех подписей с помощью простой корректировки соответствующего стиля. С помощью стилей можно выполнить любое форматирование текста. При отсутствии достаточного опыта такой подход потребует дополнительных затрат времени, но, научившись изменять оформление документов путем манипуляций со стилями, вы сможете экономить-многие часы.


Графические объекты

Word умеет внедрять в свои документы объекты других приложений Windows, например графического редактора Paint. Но на этом оформительские возможности Word не заканчиваются. В пакет Microsoft Office XP входит несколько специализированных модулей, доступных в любом из шести основных приложений, со своей стороны предлагающих пользователю команды и инструменты быстрого доступа к таким дополнительным компонентам. Эти модули формируют и добавляют в документы объекты определенных типов. С одним из них — инструментом WordArt — вы познакомились на занятии 1.


Упражнение 6. Фигуры и надписи

В Word, PowerPoint и Excel есть специальная панель инструментов Рисование (Drawing), которая позволяет украшать документы разнообразными фигурами. Чтобы такие фигуры были видны в документе Word, переключитесь в режим разметки страницы или в режим электронного документа. Если панель инструментов, показанная на рис. 6.17, отсутствует на экране, щелкните на кнопке Рисование (Drawing) панели инструментов Стандартная (Standard).

Рис. 6.17. Панель инструментов рисования

Теперь давайте нарисуем несколько фигур.

  1. Введите в документ текст Это прямоугольник.

  2. В панели инструментов Рисование (Drawing) щелкните на кнопке Прямоугольник (Rectangle).

  3. Переместите указатель выше и правее введенного текста, нажмите кнопку мыши и растяните диагональ прямоугольника так, чтобы он охватил текст. Предполагалось, что прямоугольник будет играть роль рамки, выделяя текст. Но сам текст пропал. Почему так получилось? Дело в том, что любая фигура имеет границу и внутреннюю область. По умолчанию граница рисуется тонкой черной линией, а внутренняя область закрашивается белым цветом. Эти параметры легки изменить.

  4. Щелкните в панели инструментов Рисование (Drawing) на стрелке справа от кнопки Цвет заливки (Fill Color) и в раскрывшейся палитре выберите пункт Нет заливки (No Fill). Прямоугольник станет прозрачным, и текст снова появится на экране.

  5. Щелчком на стрелке справа от кнопки 11вет линии (Line Color) раскройте палитру цвета границы фигуры и выберите в ней синий квадрат.

  6. Щелкните в той же панели инструментов на кнопке Объем (3D) и в раскрывшейся палитре вариантов объемного оформления выберите второй значок первого ряда. Теперь текст окружен синим объемным прямоугольником (рис. 6.18).

Рис. 6.18. Фигуры в документе Word

  7. Щелкните на кнопке Автофигуры (AutoShapes) панели инструментов Рисование (Drawing).

  8. Выберите в раскрывшемся меню пункт Фигурные стрелки > Стрелка влево (Block Arrows > Left Arrow).

  9. Растяните мышью стрелку ниже прямоугольника, как показано на рис. 6.19.

  10. С помощью палитры кнопки Цвет заливки (Fill Color) залейте стрелку зеленым цветом.

  11. Щелкните на кнопке Тип лини и (Line Style) и выберите линию толщиной 3 пункта. Любая фигура имеет восемь управляющих маркеров, которые отображаются в виде залитых квадратов в углах и по серединам границ габаритного контейнера фигуры и позволяют изменять ее размеры. Сверху от габаритного контейнера располагается еще одна точка, окрашенная в зеленый цвет. Поместив в нее указатель мыши, можно свободно поворачивать габаритный контейнер, а с ним и всю фигуру. Некоторые фигуры дополнительно имеют одну или несколько управляющих точек в виде желтых ромбов, позволяющих изменять форму фигуры. Стрелка обладает одной такой точкой.

  12. Захватите правый средний маркер нарисованной стрелки и перетащите его вправо. Стрелка станет шире.

  13. Перетащите управляющую точку вправо. Стрелка изменит свою форму и станет примерно такой, как показано на рис. 6.19.

Рис. 6.19. Изменение формы и расположения фигур

  14. В панели инструментов Рисование (Drawing) выберите команду Автофигуры > Выноски > Скругленная прямоугольная выноска (AutoShapes > Callouts> Rounded Rectangular Callout).

  15. Растяните выноску, показанную на рис. 6.20, чтобы она перекрывала стрелку и прямоугольник. При необходимости скорректируйте форму выноски с помощью управляющих маркеров.

  16. Щелкните внутри выноски и введите текст Это стрелка влево. Не забудьте, что при редактировании текста кнопка Выбор объектов (Select Objects) должна быть отжата. Подобные выноски позволяют располагать надписи в любом месте документа, на схемах, рисунках и графиках.

  17. На самом деле надпись можно добавить в любую автофигуру. Щелкните на кнопке Выбор объектов (Select Objects), а затем на стрелке, чтобы выделить ее.

  18. Щелкните на кнопке Надпись (Text Box), а затем введите текст Надпись на стрелке. Он появится прямо на зеленом поле стрелки, будет перемещаться вместе с ней и никогда не выйдет за границы этой стрелки.

  19. Снова щелкните на кнопке Выбор объектов (Select Objects), так как ввод надписи автоматически отключает этот режим, а затем щелчком выделите объемный прямоугольник.

  20. В панели инструментов Рисование (Drawing) выберите команду Действия > Порядок > На передний план (Draw > Order > Bring To Front). Порядок расположения объектов изменится. Если раньше выноска располагалась поверх объемного прямоугольника, то теперь прямоугольник оказывается сверху выноски.

Примечание

Фигура, которую вы хотите отформатировать, должна быть выделена, то есть окружена габаритным контейнером с маркерами. Если маркеров нет, щелкните на кнопке Выбор объектов (Select Objects) панели инструментов Рисование (Drawing), а затем на той фигуре, которую нужно модифицировать. Чтобы выключить режим выделения и продолжить редактирование текста документа, повторно щелкните на кнопке Выбор объектов (Select Objects).

Меню Действия (Draw) и Автофигуры (AutoShapes) позволяют рисовать самые разнообразные графические объекты и выполнять с ними многие операции, такие как группировка, равномерное распределение по странице или вращение. Попробуйте сами изучить возможности панели инструментов Рисование (Drawing). С ее помощью можно рисовать достаточно сложные схемы, не прибегая к услугам графических редакторов.


Упражнение 7. Библиотека картинок

Microsoft Office XP предлагает обширную библиотеку рисунков, в которой можно найти подходящую картинку для оформления практически любого документа. Поскольку Word — это текстовый редактор, оперирующий с символами, картинки, так же как и фигуры, не просто помещаются в то или иное место страницы, они оказываются привязанными к определенному символу документа. Это очень удобно.. При редактировании многостраничного файла текст может сместиться на несколько страниц, при этом произойдет аналогичное перемещение всех связанных с текстом рисунков и логика документа не нарушится. Чтобы добавить рисунок библиотеки ClipArt в документ Word, созданный в предыдущем упражнении, выполните следующие шаги.

  1. Щелкните в конце строки Это прямоугольник, нажмите несколько раз клавишу Enter, чтобы текстовый курсор оказался ниже зеленой стрелки, и введите текст Вставляем рисунок.

Примечание

В документе, показанном на рис. 6.19, только строка Это прямоугольник является настоящим абзацем документа Word. Все остальные надписи расположены на автофигурах и являются их неотъемлемой частью. Эти надписи исчезают с экрана при переключении в обычный режим просмотра.

  2. Выберите команду Вставка >Рисунок > Картинки (Insert > Picture > ClipArt). Откроется окно Вставка картинки (Insert ClipArt), показанное на рис. 6.20.

  3. Введите ключевое слово Животные (Animals) для поиска картинки в поле Искать текст (Search text) в разделе Поиск клипа (Search for) и щелкните на кнопке Найти (Search). В поле Результаты (Results) появятся имеющиеся в коллекции картинки с изображениями животных.

Рис. 6.20. Окно Вставка картинки области задач

  4. Наведите указатель мыши на понравившуюся картинку. Щелкните на стрелке, появившейся справа от картинки и в раскрывшемся меню выберите пункт Вставить (Insert). Рисунок будет вставлен в конец строки Вставляем рисунок.

  5. Захватите угловой маркер рамки рисунка и перетащите его по направлению к центру рисунка, чтобы немного уменьшить размеры объекта.

  6. Захватив рисунок мышью за середину, перетащите его влево, чтобы он оказался между словами Вставляем и рисунок, как показано на рис. 6.21. Когда рисунок выделен, в окне Word появляется панель инструментов Настройка изображения (Picture), показанная на рис. 6.22, которая позволяет изменять контрастность, яркость, режим обтекания текстом и другие параметры рисунка.

Рис. 6.21. Добавление рисунка

Примечание

Теперь рисунок привязан к слову Вставляем. Попробуйте добавить несколько абзацев перед строкой Вставляем рисунок или несколько слов в начало этой строки. Вы заметите, что рисунок перемещается вместе со словом Вставляем.

Рис. 6.22. Панель инструментов для настройки изображения

Примечание

В контекстном меню любого выделенного объекта доступна команда ГиnepccbiAKa(l-lyperlink), которая превращает текст, рисунок, фигуру и любой другой элемент документа в гиперссылку на другой документ или на web-страницу Интернета.

  7. Щелкните на добавленном рисунке правой кнопкой мыши и выберите в контекстном меню команду Гиперссылка (Hyperlink).

  8. Вокнедиалога Добавление гиперссылки (Insert Hyperlink), показанном на рис. 6.23, укажите имя файла или URL документа Интернета либо выберите нужный объект в списке.

  9. Щелкните на кнопке ОК.

Рис. 6.23. Окно диалога добавления гиперссылки

Четыре кнопки в левой части этого окна диалога позволяют связать объект с ги-перссылками следующих категорий:

  • Имеющимся файлом, веб-страницей (Existing File Or Web Page) — недавно открывавшиеся файлы, недавно просматривавшиеся web-страницы или любой другой ресурс, имя которого можно ввести в поле Адрес: (Address:);

  • Местом в этом документе (Place In This Document) — заголовки и закладки текущего документа;

  • Новым документом (Create New Document) — ссылка на несуществующий документ, который будет создан позже;

  • Электронной почтой (E-mail Address) — электронный адрес удаленного пользователя. При щелчке на такой ссылке запускается программа Outlook, которая позволяет отправить письмо по адресу гиперссылки.

Когда гиперссылка назначается текстовому фрагменту, Word окрашивает текст другим цветом и подчеркивает его, сигнализируя о наличии гиперссылки. Рисунки „ с гиперссылками никак не выделяются. Чтобы найти такие ссылки, перемещайте '' указатель по всем рисункам документа. Если рисунок связан с гиперссылкой, на экране появится всплывающая подсказка с именем ресурса, на который ссылается рисунок.

  10. Чтобы добавить в документ еще один рисунок, переместите текстовый курсор в ту точку, куда нужно вставить рисунок, и с помощью области задач переключитесь в окно Вставка картинки (ClipArt).

  11. Щелкните на кнопке Изменить (Modify) окна Вставка картинки (ClipArt), чтобы вернуться к разделу Поиск клипа (Search for), и повторите описанные выше действия.

Библиотека картинок обладает широкими возможностями сортировки и поиска картинок по ключевым словам. Из окна Вставка картинки (ClipArt) можно связаться с Интернетом и поискать картинки на специальном сервере компании Microsoft, Откуда их можно перенести в локальную библиотеку. Для этого выберите в разделе См.также (See Also) раздел Коллекция картинок в Интернете (Clips Online). Окно Вставка картинки (ClipArt) также позволяет импортировать в библиотеку рисунки из графических файлов различных форматов.


Контрольное упражнение

Word предлагает огромное количество приемов форматирования текста и объектов. Контрольное упражнение поможет освоить еще несколько полезных операций.

  1. Создайте нумерованный список из четырех пустых абзацев.

  2. Добавьте в каждый абзац по одному рисунку библиотеки картинок, выравняв их размеры.

  3. Разместите абзацы с рисунками в два столбца. Теперь на странице документа должны быть видны четыре пронумерованных рисунка.

  4. Добавьте ниже рисунков еще один абзац с текстом. Он автоматически получит номер 5 и разместится во втором столбце.

    • Как отменить нумерацию абзаца и расположить его ниже столбцов, чтобы он занял всю ширину страницы?

  5. Увеличьте левый отступ пятого абзаца.

    • Как с помощью панели инструментов изменить отступ абзаца ?

  6. Обведите все четыре рисунка овалами с прозрачным заполнением и красной границей толщиной в 6 пунктов.

  7. Выделите в пятом абзаце несколько слов и назначьте им шрифт Arial Cyr размером 18 пунктов и курсивное начертание.

  8. Добавьте в нижнюю часть документа еще один абзац с несколькими строками текста.

  9. Выделите первые три слова этого абзаца тем же шрифтом, которым выделялись слова на шаге 14 упражнения 5.

    • Как скопировать формат текста, используя кнопку Формат по о'бразцу (Fonnat Painter) панели инструментов?

  10. С помощью табуляций добавьте в конец документа табличку из четырех столбцов с выравниванием чисел по правому краю па отметках 2,6,10 и 14 см и вертикальными линиями в позициях 3, 7 и 11 см.


Подведение итогов

Вы получили представление о том, как форматировать текст, создавать и назначать стили, настраивать отступы и интервалы, пользоваться табуляциями, добавлять в документы Word фигуры и рисунки. Не останавливайтесь па достигнутом, старайтесь не только постоянно применять известные инструменты, но и расширять свой кругозор, пытаясь изменять еще незнакомые вам параметры окон диалога Word и пользуясь всевозможными командами контекстных меню объектов и кнопками панелей инструментов. Для получения подсказок и разъяснений обращайтесь к справочной системе Microsoft Office.

На следующем занятии вы научитесь строить таблицы и пояснять текстовое содержание диаграммами и графиками.


Занятие №3

Таблицы и графики

ТЕМА ЗАНЯТИЯ

На этом занятии описываются инструменты создания и форматирования таблиц, а также модуль Microsoft Chart, позволяющий представлять табличные данные в виде диаграмм и графиков. На занятии обсуждаются следующие темы:

  • построение таблицы;

  • добавление и удаление строк и столбцов;

  • объединение и разбиение ячеек;

  • форматирование таблиц;

  • преобразование табулированных данных в таблицу;

  • построение диаграмм на базе таблицы;

  • форматирование диаграмм и графиков.


Таблицы

Таблицы используются для представления самой разнообразной числовой и текстовой информации, которую можно упорядочить по одному или нескольким критериям. Word обладает обширным набором инструментов для построения и форматирования таблиц, что позволяет строить очень сложные таблицы с любым мыслимым оформлением. Обратите внимание, что в Word для работы с таблицами отведен целый пункт Главного меню.


Упражнение 1. Добавление таблицы

  1. Откройте новый или существующий документ. Переключитесь в обычный режим просмотра и поместите текстовый курсор в конец того абзаца, после которого нужно добавить таблицу.

  2. Нажмите клавишу Enter и введите заголовок План выпуска продукции.

  3. С помощью раскрывающегося списка Стиль (Style) панели инструментов Форматирование (Formatting) назначьте ему стиль Заголовок 3 (Heading 3).

  4. Щелкните на кнопке Добавить таблицу (Insert Table).

  5. В раскрывшейся палитре с клетками щелкните на четвертой клетке третьей строки. Выбранная клетка задает размер таблицы в ячейках. В результате выполненных действий в документ будет вставлена таблица размером 3х4 ячейки, показанная на рис. 7.1.

Рис.7.1. Добавление таблицы

Примечание

Если палитра кнопки Добавить таблицу (Insert Table) не позволяет создать таблицу с нужным числом ячеек, выберите команду Таблица > Добавить > Таблица (Table > Insert > Table), в открывшемся окне диалога введите параметры создаваемой таблицы и щелкните на кнопке ОК.

  6. Теперь следует наполнить таблицу полезной информацией. Щелкните в первой ячейке первой строки и введите текст Название товара.

  7. Нажмите клавишу Tab. Курсор переместится во вторую ячейку первой строки. Введите текст Январь.

  8. При каждом последующем нажатии клавиши Tab курсор будет перемещаться последовательно по всем ячейкам таблицы, позволяя вводить нужные данные. Заполните таблицу в соответствии с рис. 7.2.

Рис. 7.2. Ввод данных в таблицу

Примечание

Для перехода к предыдущей ячейке нажимайте клавиши Shift+Tab. Для перемещения по ячейкам таблицы можно также пользоваться клавишами со стрелками либо просто щелкать мышью на нужной ячейке.

  9. После ввода числа в последнюю ячейку третьей строки снова нажмите клавишу Tab. Таблица автоматически увеличится на одну строку, и вы сможете заполнить еще четыре ячейки. Таким образом, нет особой нужды заранее рассчитывать точное число строк таблицы. По мере ввода данных Word добавит столько строк, сколько будет нужно. Текст ячеек таблицы можно форматировать точно так же, как и любой другой текст документа Word. Единственное отличие состоит в том, что выравнивание текста выполняется не относительно полей страницы, а относительно границ каждой ячейки. Настраивая вид ячеек, можно выделять конкретные ячейки, группы строк или столбцов и всю таблицу целиком. Назначаемые режимы форматирования и выравнивания текста будут влиять только на выделенные ячейки. Поскольку абзац, предшествующий таблице, был выделен стилем Заголовок 3 (Heading 3), все ячейки таблицы получили в наследство тот же стиль. Но этот стиль предназначен для заголовка. Давайте изменим стиль ячеек таблицы.

  10. Выбором команды Таблица > Выделить > Таблица (Table > Select > Table) выделите всю таблицу (при выполнении этой команды текстовый курсор должен находиться в одной из ячеек выделяемой таблицы) и выберите в раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting) пункт Обычный (Normal).

Рис. 7.3. Форматирование текста таблицы

  11. Щелкните мышью левее первой ячейки верхней строки. Будет выделена вся верхняя строка таблицы.

  12. Щелкните на кнопке По центру (Center) панели инструментов Форматирование (Formatting),.чтобы центрировать содержимое ячеек. Затем нажатием клавиш Ctrl+B назначьте тексту выделенной строки полужирное начертание.

  13. Поместите указатель мыши в первую ячейку второй строки чуть правее левой границы ячейки, чтобы значок указателя принял форму наклонной стрелки (рис. 7.3), и протащите мышь вниз, выделив этим приемом первые ячейки строк со второй по четвертую.

  14. Нажатием клавиш Ctrl+I назначьте выделенным ячейкам курсивное начертание.

  15. В любой момент можно изменить конфигурацию таблицы, добавляя в нее строки и столбцы. Щелкните во втором столбце таблицы и выберите команду Таблица > Добавить » Столбцы справа (Table > Insert > Columns To The Right).

Примечание

Чтобы удалить строку, столбец или группу ячеек, выделите удаляемые ячейки и выберите соответствующую команду подменю Таблица » Удалить (Table > Delete). Нажатие клавиши Delete не удаляет выделенные ячейки, а лишь стирает их содержимое.

  16. Щелкните в верхней ячейке нового столбца и введите слово Апрель. Нажмите клавишу -L и введите число во вторую ячейку нового столбца. Аналогичным образом заполните все пустые ячейки.

  17. Щелчком на верхней границе первой ячейки третьего столбца выделите весь столбец, как показано на рис. 7.4.

Рис. 7.4. Перетаскивание столбца

  18. Поместите указатель в ячейку со словом Апрель и нажмите левую кнопку мыши.

  19. Перетащите мышь правее первой ячейки пятого столбца и отпустите левую кнопку. Третий столбец переместится в конец таблицы. Word предлагает еще один интересный способ добавления и удаления ячеек. Их можно просто нарисовать. Это очень быстрая и удобная методика построения таблиц, однако она требует определенных навыков и умения точно манипулировать мышью.

  20. Попробуйте «дорисовать» одну широкую ячейку в верхней части таблицы. Для этого выберите команду Таблица > Нарисовать таблицу (Table > Draw Table). Word автоматически переключит документ в режим разметки страниц, так как только этот режим позволяет оценивать реальные размеры изображаемых элементов документа. Значок указателя мыши примет форму карандаша, и на экране появится панель инструментов Таблицы и границы (Tables And Borders), показанная на рис. 7.5. Она обеспечивает доступ к инструментам форматирования и редактирования таблиц.

Рис. 7.5. Панель инструментов Таблицы и границы

  21. Поместите указатель в верхний левый угол таблицы и нажмите левую кнопку мыши.

Рис. 7.6. Нарисованная ячейка

  22. Протащите мышь вправо до правой границы таблицы и чуть вверх, чтобы появилась еще одна широкая ячейка, показанная на рис. 7.6.

  23. Введите в новую ячейку текст План компании Геркулес на 2002 год.


Упражнение 2. Размер ячеек

Таблицу, построенную в предыдущем упражнении, хотелось бы сделать немного поуже. Кроме того, следует расширить первый столбец, чтобы слова Панели квадратные выводились одной строкой, и для лучшей читабельности текста немного увеличить высоту всех строк.

  1. Если режим отображения линеек отключен, выберите команду Вид > Линейка (View > Ruler). Обратите внимание: когда курсор находится в пределах таблицы, на вертикальной и горизонтальной линейках появляются специальные маркеры, позволяющие изменять высоту и ширину ячеек (рис. 7.7). Кроме того, на горизонтальной линейке присутствуют маркеры регулировки отступов текста текущей ячейки или выделенного столбца от границ ячеек. Самостоятельно подвигайте эти маркеры и изучите их воздействие на вид таблицы.

  2. Перетащите маркер границы между первой и второй строками таблицы вниз на 1 см.

  3. Щелкните на верхней ячейке таблицы.

Рис. 7.7. Маркеры линеек

Рис. 7.8. Окно диалога свойств таблицы

  4. В панели инструментов Таблицы и границы (Tables And Borders) щелкните на стрелке слева от кнопки режима выравнивания и выберите в открывшейся палитре кнопку Выровнять по центру (Align Center).

Рис. 7.9. Настройка размеров таблицы

  5. Чтобы увеличить шрифт заглавной ячейки, выберите в раскрывающемся списке Размер (Font Size) панели инструментов Форматирование (Formatting) число 18.

  6. Чтобы точно задать ширину таблицы, выберите команду Таблица > Свойства таблицы (Table > Table Properties). Откроется окно диалога, показанное на рис. 7.8. Оно имеет четыре вкладки, с помощью которых можно настраивать параметры выделенных строк, столбцов или ячеек, а также таблицы в целом.

  7. На вкладке Таблица (Table) установите флажок ширина (Preferred Width).

  8. Введите в одноименный счетчик число 30.

  9. Щелкните на кнопке ОК. Теперь ширина таблицы будет равна 30 делениям, как показано на рис. 7.9.

  10. Переместите указатель на вертикальную линию границы между первым и вторым столбцом, чтобы значок принял форму двунаправленной стрелки, и нажмите левую кнопку мыши.

  11. Перетащите границу вправо на такое расстояние, чтобы текст всех ячеек первого столбца помещался в одну строку. Мы настроили ширину первого столбца, но получилось так, что второй столбец оказался слишком узким. Давайте выровняем ширину четырех правых столбцов таблицы.

  12. Нажмите левую кнопку мыши в ячейке Январь и протащите указатель до правой нижней ячейки таблицы. Окажутся выделенными четыре правых столбца.

  13. Щелкните на кнопке Выровнять ширину столбцов (Distribute Columns Evenly). Ширина выделенных столбцов станет одинаковой.

  14. Выделите последние четыре строки таблицы, протащив мышь слева от них. Выберите команду Таблица > Свойства таблицы (Table > Table Properties). На вкладке Строка (Row) открывшегося окна диалога установите флажок Высота (Specify Height) и введите в одноименный счетчик число 1. Затем щелкните ил кнопке ОК. Таблица станет такой, как показано на рис. 7.10.

Рис. 7.10. Таблица с настроенными ячейками


Упражнение 3. Разбиение и объединение ячеек

Построенная таблица достаточно проста. В реальной жизни часто возникает надобность сформировать таблицу с подзаголовками, объединяющими серию строк или столбцов. Чтобы научиться объединять ячейки, выполните следующие шаги.

  1. Щелкните в ячейке с текстом Январь.

  2. Раскройте в панели инструментов Таблицы и границы (Tables And Borders) па литру кнопки вставки объекта.

  3. Выберите пункт Добавить строки выше (Insert Rows Above).

  4. В новой строке выделите четыре правые ячейки, как показано на рис. 7.11.

Рис. 7.11. Объединение ячеек

  5. Щелчком на кнопке Объединить ячейки (Merge Cells) преобразуйте четыре вы деленные ячейки в одну.

  6. Введите текст По месяцам.

  7. Выделите ячейку с текстом Название товара и ячейку над ней. Щелчком на кнопке Объединить ячейки (Merge Cells) объедините их.

  8. Щелчком на значке Выравнять по центру (Align Center) в палитре кнопки выравнивания объектов подравняйте надпись в образовавшейся большой ячейке. Теперь заголовки строк и столбцов выглядят привлекательнее.

Примечание

Иногда таблицы оказываются достаточно высокими и не помещаются на одной странице. Чтобы заголовки столбцов дублировались при переносе части таблицы на следующую страницу, выделите первые несколько строк таблицы, которые должны повторяться на каждой странице, и выберите команду Таблица > Заголовки (Table > Heading Rows Repeat). Для отключения этого режима повторно выберите ту же самую команду.

  9. Ячейки "можно не только объединять, но и разделять. Выделите три нижние ячейки столбца Февраль и щелкните на кнопке Разбить ячейки (Split Cells). Откроется окно диалога, показанное на рис. 7.12.

Рис. 7.12. Разбиение ячеек

  10. Сбросьте флажок Объединить перед разбиением (Merge Cells Before Split). Остальные параметры оставьте без изменения. Это заставит Word разделить каждую из трех ячеек пополам.

  11. Щелкните на кнопке О К и введите в новые ячейки произвольные числа. Теперь таблица будет выглядеть примерно так, как показано на рис. 7.12.


Упражнение 4. Форматирование таблицы

Давайте немного приукрасим таблицу, изменив линии ячеек.

  1. Щелкните в верхней ячейке таблицы, созданной в предыдущих упражнениях.

  2. Выберите в раскрывающемся списке Тип линии (Line Style) панели инструментов Таблицы и границы (Tables And Borders) двойную линию.

  3. Щелкните в той же панели инструментов на стрелке справа от кнопки настройки границ. Раскрывшаяся палитра показывает, что активная ячейка не имеет границ, выполненных двойной линией.

  4. Щелчком на кнопке Нижняя граница (Bottom Border) замените нижнюю одинарную границу ячейки на двойную (рис. 7.13).

  5. Выделите всю таблицу, в списке Тип линии (Line Style) выберите одинарную линию.

  6. В списке Толщина линии (Line Weight) выберите толщину 3 пункта.

  7. Щелчком на кнопке Внешние границы (Outside Border) палитры настройки грат ниц очертите таблицу жирной линией. Ручной настройкой границ ячеек можно создать сколь угодно сложное оформление таблицы. Но, как правило, пользователей устраивает один из стандартных стилей, предлагаемых инструментом автоформата таблиц.

  8. Щелкните в любой точке, не выходящей за пределы таблицы и выберите команду Таблица > Автоформат (Table > Table AutoFormat). Откроется окно диалога, показанное на рис. 7.14.

Рис. 7.13. Настройка границ

Примечание

Окно диалога Автоформат (AutoFormat), в приложении Word XP имеет более сложную структуру, чем в предыдущих версиях Office. Число имеющихся готовых вариантов формата таблица здесь значительно больше, чем раньше. Кроме того, появилась возможность самостоятельно создавать и изменять стили таблиц.

  9. Перебирайте пункты списка Форматы (Formats) и наблюдайте предлагаемое оформление в разделе Образец (Preview) окна диалога.

Рис. 7.14. Выбор автоформата таблицы

Рис. 7.15. Окончательный вид таблицы

  10. Отыскав подходящий вариант, попробуйте установить или сбросить некоторые флажки двух нижних разделов окна диалога. Это позволит модифицировать отдельные элементы выбранного автоформата. Затем щелкните на кнопке ОК.

Для таблицы этого упражнения я выбрал автоформат Столбцы 4 (Columns 4) и не стал менять состояние флажков. Результат такого форматирования таблицы показан на рис. 7.15. Он не совсем удачен, так как таблица имеет сложную структуру заголовков и ячеек. Для более простых таблиц автоформат дает прекрасные результаты.


Графики и диаграммы

Таблицы удобны для хранения точных числовых данных, но человеку часто нужны не точные цифры, а общее представление о величине какого-либо параметра. Поэтому табличные данные полезно дублировать диаграммами, которые отображают информацию с помощью графических элементов, таких как гистограммы, круговые диаграммы или графики.


Упражнение 5. Построение диаграммы на базе таблицы

Если раньше вы не пользовались таблицами Word, весьма вероятно, что какая-то часть ваших данных хранится в обычном текстовом файле. Теперь, почувствовав всю мощь программы Word, вы решили перенести их в красиво оформленную таблицу, а заодно построить диаграмму. Как быстрее решить эту задачу?

  1. В Главном меню Windows выберите команду Программы > Стандартные > Блокнот (Programs > Accessories > Notepad).

Рис. 7.16. Пример текстового файла

  2. Нажмите клавишу Tab и введите слово Январь.

  3. Сндва нажмите Tab и введите Февраль.

  4. Продолжайте ввод слов и чисел в соответствии с рис. 7.16, отделяя их друг от друга символом табуляции.

  5. Выберите команду Файл > Сохранить (File > Save) и запишите файл в папку Мои документы (My Documents) под именем Таблица.txt.

  6. Закройте окно Блокнота. Теперь у вас есть пример обычного текстового файла с небольшой таблицей. Давайте импортируем ее в Word и проиллюстрируем имеющиеся числовые данные диаграммой.

  7. В программе Word щелкните на кнопке Открыть (Open) панели инструментов Стандартная (Standard). В списке Тип файлов (Files Of Type) окна диалога открытия файла выберите пункт Все файлы (All Files), найдите только что созданный файл Таблица.1х1 и откройте его. В окне диалога Преобразование файла (Convert File) дважды щелкните на строке Только текст (Text Only). Таблица появится в окне Word. Она может оказаться немного кривоватой, но это не имеет значения. Главное, что столбцы таблицы разделены символами табуляции.

  8. Нажатием клавиш Ctrl+A выделите весь документ. Затем выберите команду Таблица > Преобразовать > Преобразовать в таблицу (Table > Convert > Text To Table).

  9. Проверьте, чтобы параметры окна диалога Преобразовать в таблицу (Convert Text To Table) были настроены в соответствии с рис. 7.17.

Рис. 7.17. Преобразование текста в таблицу

  10. Щелкните на кнопке Автоформат (AutoFormat).

Примечание

Если данные текстового файла разделены не табуляциями, а, скажем, запятыми, выберите в разделе Разделитель (Separate Text At) окна диалога преобразования положение переключателя Другой (Other) и введите в одноименное поле соответствующий символ (запятую).

  11. В окне диалога Автоформат таблицы (Table AutoFormat) выберите вариант Стандарт 1 (Classic 1). Затем два раза щелкните на кнопке ОК. Таблица готова! Microsoft Office позволяет создавать диаграммы двумя способами: с помощью мастера диаграмм Excel, который уже встречался вам на занятии 2, или с помощью модуля Microsoft Graph, который доступен в различных приложениях Office. Сейчас давайте воспользуемся вторым вариантом.

  12. Щелкните в любой ячейке полученной таблицы и выберите команду Таблица > Выделить > Таблица (Table > Select > Table).

  13. Выберите команду Вставка ^ Рисунок > Диаграмма (Insert > Picture > Chart). В документе Word появится диаграмма и откроется окно таблицы данных Microsoft Graph XP. Информация из таблицы Word будет перенесена в окно Graph XP, а меню и панели инструментов Word заменятся на соответствующие компоненты модуля Graph, как показано на рис. 7.18.

  14. Щелкните на пустой области документа Word. Окно данных, панели инструментов и меню модуля Graph XP исчезнут, а ниже таблицы Word разместится диаграмма, представляющая данные этой таблицы в графической форме.

Рис. 7.18. Построение диаграммы на базе таблицы Word


Упражнение 6. Форматирование диаграмм и графиков

Скорее всего, вас не устроит та диаграмма, которая генерируется по умолчанию. Модуль Microsoft Graph предоставляет широчайшие возможности форматирования. Вы можете выбирать тип диаграммы, изменять цвет рядов данных, добавлять заголовки, перемещать легенду, настраивать оси, их шкалы и метки делений, добавлять подписи данных и изменять множество дополнительных параметров, влияющих на способ представления данных. В этом упражнении на примере диаграммы, построенной на базе таблицы Word, будут рассмотрены лишь некоторые из доступных приемов форматирования.

  1. Чтобы модифицировать диаграмму, нужно снова открыть модуль Microsoft Graph. Для этого дважды щелкните на диаграмме.

  2. Щелчком на кнопке Режим таблицы (View Datasheet) скройте таблицу данных Graph. Сейчас мы не будем изменять данные. Таблица данных Graph похожа на лист Excel. Если вам придется вручную вводить данные для диаграмм Graph, пользуйтесь приемами, изложенными в упражнениях занятия 9.

  3. В панели инструментов Стандартная (Standard) раскройте палитру кнопки типа диаграммы и выберите подходящий тип, например График (Line Chart).

Примечание

Способы форматирования диаграмм Microsoft Graph похожи на приемы оформления диаграмм Excel, о которых рассказывается на занятии 11.

Примечание

Если вас не устраивают типы диаграмм, представленные в палитре кноп- ки панели инструментов, выберите команду Диаграмма > Тип диаграммы (Chart > Chart Type). Откроется окно диалога, первая вкладка которого предлагает на выбор больше сотни стандартных вариантов диаграмм, а вторая дает пользователю возможность сконструировать свой собственный тип диаграммы.

  4. Легенда диаграммы расположена неудобно, давайте переместим ее вниз. Для этого щелкните на легенде правой кнопкой мыши, выберите в контекстном меню команду Формат легенды (Format Legend) и на вкладке Размещение (Placement) открывшегося окна диалога выберите положение переключателя Внизу, посередине (Bottom). Затем щелкните на кнопке ОК.

  5. Захватите мышью правый нижний маркер габаритного прямоугольника диаграммы и перетащите его вправо вниз, чтобы сделать диаграмму немного крупнее, как показано на рис. 7.19.

Теперь давайте приукрасим подписи осей, изменим сетку, на фоне которой выводится график, и увеличим маркеры данных, чтобы они были лучше видны.

  6. Дважды щелкните на числах меток вертикальной оси графика. В открывшемся окне диалога разверните вкладку Шкала (Scale), показанную на рис. 7.20.

  7. Сбросьте флажки Максимальное значение (Maximum) и Цена основных делений (Major Unit), чтобы отключить автоматическую настройку этих параметров.

  8. В одноименные поля после флажков введите числа 80 и 20 соответственно.

  9. Щелкните на кнопке ОК. Четыре другие вкладки окна диалога форматирования осей позволяют настраивать вид осей, шрифт меток делений, числовой формат меток и режим их выравнивания.

  10. Чтобы убрать серый фон графика, выберите команду Диаграмма > Параметры диаграммы (Chart > Chart Options), которая открывает окно диалога параметров диаграммы. Шесть вкладок этого окна содержат следующие параметры:

Рис. 7.19. Форматирование диаграммы

  • Заголовки (Titles) — названия диаграммы, вертикальных и горизонтальных осей;

  • Оси (Axes) — режимы отображения осей категорий и значений;

  • Линии сетки (Gridlines) — флажки включения и отключения вертикальных и горизонтальных линий сетки фона диаграммы;

  • Легенда (Legend) — режим отображения и способ расположения легенды диаграммы;

  • Подписи данных (Data Labels) — переключатель, дающий возможность выводить различные подписи рядом с маркерами данных;

  • Таблица данных (Data Table) — флажки настройки режима вывода таблицы отображаемых данных под горизонтальной осью диаграммы.

  11. На вкладке Линии сетки (Gridlines), показанной на рис. 7.21, сбросьте флажок основные линии (Major Gridlines) в разделе Ось Y (значений) (Value (Y) Axis).

  12. Установите одноименный флажок в разделе Ось Х (категорий) (Category (X) Axis).

  13. Щелчком на кнопке ОК закройте окно диалога. Горизонтальные линии сетки будут заменены на вертикальные.

  14. Щелкните на области построения диаграммы. В меню Формат (Format) выберите первую команду. Ее название начинается со слова Выделенный (Selected), после которого следует название выделенного элемента. В данной ситуации это будет команда Выделенная область построения диаграммы (Selected Plot Area).

Рис. 7.20. Форматирование осей диаграммы

  15. В открывшемся окне диалога выберите положение Прозрачная (None) переключателя Заливка (Area), чтобы отменить заливку диаграммы. Затем щелкните на кнопке ОК.

Рис. 7.21. Параметры диаграммы

  16. Чтобы выйти из режима редактирования диаграммы и закрыть модуль Microsoft Graph, щелкните на свободном пространстве документа Word. Теперь таблица и график будут выглядеть так, как показано на рис. 7.22.

  17. Сохраните документ, он пригодится в контрольном упражнении.

Рис. 7.22. Окончательный вид диаграммы


Контрольное упражнение

С помощью этого упражнения попробуйте самостоятельно изучить некоторые приемы форматирования таблиц и диаграмм.

  1. Откройте файл, созданный в упражнении 6.

  2. Добавьте в конец таблицы еще один столбец и заполните его ячейки.

    • Как обновить диаграмму, чтобы в ней появились данные добавленного столбца?

  3. Залейте фон первой строки и первого столбца таблицы желтым цветом.

  4. Рассортируйте строки таблицы по возрастанию чисел в столбце Февраль.

    • Как автоматически рассортировать табличные данные?

  5. Двойным щелчком на диаграмме запустите Microsoft Graph.

  6. Дважды щелкните на подписях горизонтальной оси и в открывшемся окне диалога измените ориентировку подписей, чтобы их текст выводился вертикально.

  7. Добавьте заголовки диаграммы и осей.

    • Где назначаются заголовки элементов диаграммы?

  8. В области легенды выделите маркер ряда данных Трубы, дважды щелкните на нем и в открывшемся окне диалога измените цвет маркера на черный. Повторите эту операцию для всех рядов данных.


Подведение итогов

На этом занятии вы познакомились с приемами построения и форматирования таблиц, импорта табличных данных из текстовых файлов. Вы научились строить и оформлять диаграммы.

Следующее занятие завершает изучение приложения Word XP. Оно посвящено описанию модуля проверки орфографии и процедуры объединения документа Word с внешними табличными данными.


Занятие №4

Дополнительные возможности Word

ТЕМА ЗАНЯТИЯ

На заключительном занятии гю теме Word XP вы освоите некоторые дополнительные инструменты этого приложения:

  • язык документа;

  • проверка орфографии и грамматики;

  • слияние с внешними данными.

Microsoft Word умеет выполнять множество вспомогательных операций, значительно облегчающих работу с документом, его форматирование и проверку. Описание всех дополнительных операции Word можно найти в книге Б. Карпова Microsoft Word 2002: справочник» («Питер», 2001). На этом занятии рассматриваются два важных инструмента — модуль проверки орфографии и грамматики, позволяющий быстро выявлять и исправлять ошибки, и процедура слияния, с помощью которой красиво оформленный документ Word с пустыми полями можно связать с внешней таблицей или базой данных, получив в результате отформатированный отчет, данные которого можно оперативно обновлять.


Орфография и грамматика

В пакете Microsoft Office есть модуль автоматической проверки орфографии и грамматики. Он доступен во всех приложениях Office и позволяет с помощью одних и тех же приемов быстро проверять и корректировать как документы Word, так, например, и текст записей баз данных Access. В зависимости от конфигурации Windows и версии Office словари этого модуля могут поддерживать работу с несколькими языками.


Упражнение 1. Язык документа

По мере ввода текста каждому слову назначается атрибут, определяющий, каким языком написано слово. Эта информация используется при проверке документа для выбора словаря, которым следует руководствоваться при идентификации каждого конкретного слова. Word, как правило, сам корректно распознает язык, выбирая один из тех языков, поддержка которых установлена на компьютере. Смена языка происходит при переключении раскладки клавиатуры с английской на русскую и обратно.

Примечание

Если Word не подчеркивает слова и фразы с ошибками, значит, отключен режим автоматической проверки правописания. Чтобы включить его, выберите команду Сервис > Параметры (Tools > Options). В открывшемся окне диалога щелкните на вкладке Правописание (Spelling & Grammar) и установите флажки Автоматически проверять орфографию (Check Spelling As You Type) и Автоматически проверять грамматику (Check Grammar As You Type).

Примечание

При установке русскоязычной версии Office инсталлируются словари для русского и английского языков. Если англоязычная версия Office ХР устанавливается поверх предыдущей русской версии Office, то поддержка русского языка сохраняется.

Если Word замечает в тексте слово, написанное с ошибкой, такое слово подчеркивается красной зигзагообразной линией, как показано на рис. 8.1. Чтобы исправить слово, отредактируйте его, заменив неверные символы, или воспользуйтесь словар&м Office.

Рис. 8.1. Автоматическая проверка правописания

  1. Щелкните на подчеркнутом слове правой кнопкой мыши и выберите в контекстном меню правильный вариант написания или одну из следующих команд:

    • Пропустить все (Ignore All) — не воспринимать выделенное слово в качестве ошибочного в текущем документе;
    • Добавить (Add) — добавить слово в словарь Word и в дальнейшем считать данное написание правильным;
    • Автозамена (AutoCorrect) — настроить автоматическую коррекцию написания данного слова с помощью словаря Word. Выбрав в списке Auto-Correct (Автозамена) правильный вариант написания, вы добавляете пункт в список автозамены. При следующей ошибке в том же слове Word сам исправит неверное написание;

Примечание

Чтобы просмотреть и отредактировать список автоматической коррекции, выберите команду Сервис > Автозамена (Tools > AutoCorrect).

  • Язык (Language) — изменить язык слова;
  • Орфография (Spelling) — запустить модуль проверки орфографии.

  2. Если по каким-то причинам Word назначил фрагменту текста неверный язык, выделите этот текст и выберите команду Сервис > Язык > Выбрать язык (Tools > Language > Set Language). Откроется окно диалога, показанное на рис. 8.2.

  3. В списке окна диалога выберите язык для выделенного текста. Языки, словари которых установлены на компьютере, отмечены специальными значками (рис. 8.2).

Рис. 8.2. Выбор языка

  4. Если нет нужды проверять правописание выделенного фрагмента или невозможно указать верный язык (так бывает, например, в случае работы с математическими формулами), установите флажок Не проверять правописание (Do Not Check Spelling Or Grammar).

  5. Щелкните на кнопке ОК.

При вводе текста Word кроме орфографии автоматически проверяет грамматику (если в окне параметров установлен флажок Автоматически проверять грамматику (Check Grammar As You Type)). Неверные грамматические конструкции подчеркиваются зеленой зигзагообразной линией.

  6. Чтобы исправить грамматическую ошибку, щелкните правой кнопкой мыши на фразе, подчеркнутой зеленой линией, и выберите в контекстном меню скорректированный вариант фразы или одну из следующих команд:

    • Пропустить (Ignore) — не считать данную фразу ошибочной;
    • Грамматика (Grammar) — запустить модуль проверки грамматики.


Упражнение 2. Проверка орфографии и грамматики

Автоматическая проверка орфографии и грамматики не всегда удобна. Иногда нужно целиком сосредоточиться на основной теме документа и не хочется отвлекаться на мелкие .ошибки. При импорте текстового содержания, при неверной настройке языка документа или при обработке документа большого объема ошибок может оказаться слишком много, тогда автоматическая проверка существенно замедлит работу Word. В таких ситуациях отключите автоматическую проверку (сбросив флажки, указанные в совете предыдущего упражнения), а на последней стадии разработки документа вручную проверьте правописание с помощью следующих действий.

  1. Для перехода к началу документа нажмите клавиши Ctrl+Home.

  2. Выберите команду Сервис > Правописание (Tools > Spelling And Grammar). Откроется окно диалога, показанное на рис. 8.3, и Word начнет сканировать документ на предмет ошибок. В верхнем прокручивающемся поле этого окна появится первая наиденная фраза с ошибкой. В нижнее прокручивающееся поле выводится верное (по мнению Word) написание фразы либо список слов, которыми Word предлагает заменить ошибочное.

Рис. 8.3. Окно диалога проверки правописания

  3. Орфографические ошибки выделяются красным цветом. Для их коррекции выполняйте одно из следующих действий:

    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);
    • чтобы пропустить в текущем документе все подобные «ошибки», щелкните на кнопке Пропустить все (Ignore All);
    • для исправления слова выберите в нижнем поле один из предлагаемых вариантов и щелкните на кнопке Заменить (Change);
    • чтобы автоматически исправить в текущем документе все подобные ошибки, щелкните на кнопке Заменить все (Change All);
    • если в нижнем поле отсутствует правильный вариант написания, отредактируйте фразу в верхнем поле и щелкните на кнопке Заменить (Change), затем при необходимости подтвердите выполненную коррекцию щелчком на кнопке Да (Yes);
    • если выделенное слово должно считаться верным во всех документах, его нужно добавить в словарь Word, для этого щелкните на кнопке Добавить(Add).

  4. Грамматические ошибки выделяются зеленым цветом. При этом кнопки окна диалога проверки правописания несколько видоизменяются. Грамматические ошибки исправляются с помощью следующих операций:

    • чтобы исправить предложение, выберите один из пунктов нижнего прокручивающегося поля или вручную отредактируйте текст в верхнем поле, затем щелкните на кнопке Изменить (Change);
    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);
    • если исправления не требуются, щелкните на кнопке Пропустить(Ignore);

      щелчок на кнопке Отменить правило (Ignore Rule) отменяет проверку данного грамматического правила в текущем документе;

    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);

      кнопка Следующее (Next Sentence) инициирует пропуск текущего предложения и переход к проверке следующего.

  5. После выполнения одной из вышеуказанных операций Word продолжит поиск и выведет в окно модуля проверки очередную ошибку. Исправляйте ошибки до тех пор, пока не появится сообщение о том, что проверка документа завершена. Если необходимость в грамматической проверке отсутствует, сбросьте флажок Грамматика (Check Grammar). Если язык проверяемой фра зы был установлен неверно, что привело к обнаружению ложной ошибки, измените язык с помощью раскрывающегося списка Язык словаря (Dictionary Language).


Слияние

Суть слияния состоит в том, что вы берете документ, например образец письма, и таблицу с фамилиями и адресами людей, которым нужно разослать это письмо, а затем, автоматически объединяя образец с таблицей, генерируете набор писем. Все копии исходного письма наследуют общий текст, но содержат разную информацию в области адреса и фамилии получателя, которая заполняется на основе таблицы данных.


Упражнение 3. Создание главного документа

Для создания слияния прежде всего нужно разработать главный документ, играющий роль образца. Этот документ может иметь любое содержание. Основная идея заключается в том, что некоторые части текста заменяются полями, которые заполняются в результате слияния главного документа с таблицей данных.

  1. Откройте Word и создайте новый документ.

  2. Введите основной текст письма, но не указывайте адрес и фамилию получателя, например так, как показано па рис. 8.4. Затем сохраните документ под именем Письмо.doc.

  3. Выберите команду Сервис > Письма и рассылки > Мастер слияния (Tools > Letters and Mailings > Mail Merge Wizard). В области задач откроется окно Слияние (Mail Merge), показанное на рис. 8.5.

  4. В разделе Выбор типа документа (Select document type) выберите пункт Письма (Letters) и перейдите к следующему шагу мастера, щелкнув на команде Далее: Открытие документа (Next: Starting document).

Рис. 8.4. Текст главного документа слияния

Примечание

Пункты раздела Выбор типа документа (Select document type) определяют тип главного документа слияния. При необходимости вы всегда сможете позже изменить тип главного документа или связать с выбранным источником данных еще один главный документ.

Рис. 8.5. Окно Слияние (Mail Merge) области задач

  5. На этом этапе необходимо выбрать в качестве главного документа один из предлагаемых вариантов: использовать уже открытый документ, создать новый документ на основе шаблона или открыть существующий документ. Чтобы выбрать в качестве главного документа слияния только что созданный текст, щелкните на пункте Текущий документ (Use the current document).

  6. При необходимости отредактируйте содержание главного документа.

  7. Перейдите к следующему этану, щелкнув на команде Далее: Выбор получателей (Next: Select recipients).


Упражнение 4. Построение источника данных

Теперь нужно создать источник данных слияния (адресов и фамилий получателей письма).

  1. В разделе Выбор получателей (Select Recipients) окна Слияние (Merge Mailing) области задач выберите пункт Создание списка (Type a new list) (рис. 8.6).

Рис. 8.6. Окно Выбор получателей (Select Recipients) мастера Слияние (Mail Merge)

  2. Щелкните на команде Создать (Create) в разделе Создание списка (Type a new list). Откроется окно диалога, показанное на рис. 8.7.

Источник данных слияния представляет собой базу данных, состоящую из записей, на основе каждой из которых с помощью главного документа будет сгенерирован конкретный экземпляр письма. Все записи имеют одинаковые поля данных.

Некоторые наиболее распространенные поля заранее внесены в список окна создания источника данных. Вы можете удалить из базы данных ненужные поля и добавить свои собственные.

Рис. 8.7. Создание источника данных

Другие пункты раздела Выбор получателей (Select Recipients) позволяют выбрать в качестве источника данных имеющуюся базу данных, ранее созданную в Word или в приложении типа Access, либо адресную книгу.

Примечание

Наличие в источнике данных лишних полей никак не влияет на результат слияния, но замедляет работу программы.

  3. Щелкните на кнопке Настройка (Customize). Откроется окно диалога, пока занное на рис. 8.8.

  4. Выделите пункт Обращение (Title).

  5. Щелчком на кнопке Удалить (Delete) сотрите выделенное поле.

Рис. 8.8. Настройка полей источника данных

Рис. 8.9. Окно диалога Получатели слияния (Mail Merge Recipients)

  6. Повторяя шаги 4 и 5, удалите все поля, кроме Имя (FirstName), Фамилия (Last Name), Организация (Company Name), Адрес1 (Addressi) и Индекс (PostalCode).

  7. Щелкните на кнопке ОК.

  8. Щелкните на кнопке Закрыть (Close) окна диалога Создание источника данных (New Address List).

  9. В открывшемся окне диалога сохранения документа введите имя Гости и щелкните на кнопке Сохранить (Save). Появится показанное на рис. 8.9 окно диалога Получатели слияния (Mail Merge Recipients), в котором в настоящее время нет ни одной записи.

  10. Вам обязательно придется когда-нибудь ввести информацию в источник данных. Щелкните на кнопке Изменить... (Edit...), чтобы сделать это сейчас. Откроется форма для ввода данных. Давайте добавим несколько записей. Позже слияние сгенерирует ровно столько копий главного документа, сколько записей имеется в источнике данных.

  11. Заполните поля формы.

  12. Чтобы добавить еще одну запись, щелкните на кнопке Создать запись (New Entry).

  13. Введите еще несколько записей, перенеся в них информацию, представленную в табл. 8.1.

ТАБЛИЦА 8.1. Источник данных слияния
Номер записи | Имя | Фамилия | Организация | Адрес1 | Индекс
1 | Василий | Решетников | Премьер | Первая ул., 33 | 113114
2 | Петр | Петров | Фантом | Прямой пр., 18 | 114113
3 | Виктор | Горелов | Фантом | Четвертый проезд, 143 | 113278
4 | Игорь | Черный | Фантом | а/я 318 | 115333
5 | Илья | Николаев | Фантом | Косая ул. | 114232
6 | Леонид | Леонидов | Фантом | Зимний пр. | 211434

  14. Щелкните на кнопке Закрыть (Close), чтобы сохранить базу данных, а затем — на кнопке ОК окна Mail Merge Recipients.

Примечание

Для изменения информации источника данных щелкните в панели инструментов Слияние (Mail Merge) на кнопке Получатели (Mail Merge RecipientsEdit Data Source), а затем в открывшемся окне диалога — на кнопке Изменить (Edit). Откроется форма источника данных. Для перемещения по записям источника пользуйтесь кнопками Первая (First), Назад (Previous), Вперед (Next), Последняя (Last) в нижней части формы.

Рис. 8.10 . Панель инструментов Слияние


Упражнение 5. Размещение полей данных

Пришло время разместить поля источника данных в тексте главного документа.

  1. Перейдите к следующему этапу создания рассылки, щелкнув на команде Далее: Создание письма (Next: Write your letter) в области задач. Поместите курсор в первую строку документа и щелкните на команде Другие элементы (More Items). Откроется окно диалога Добавление поля слияния (Insert Merge Field), в котором содержится список полей источника данных, созданного в предыдущем упражнении.

  2. Выделите пункт Имя (FirstName) и щелкните на кнопке Вставить (Insert). Поле слияния появится в первой строке главного документа. Оно содержит специальный код, сообщающий программе Word, где следует размещать информацию из соответствующего ноля источника данных. Затем выберите пункт Фамилия (LastName) и снова щелкните на кнопке Вставить (Insert). Щелкните на кнопке Закрыть (Close), чтобы закрыть окно диалога Добавить поле слияния (Insert Merge Field).

  3. Введите пробел, чтобы отделить имя от фамилии.

  4. Нажмите клавишу Enter, откройте окно диалога Добавление поля слияния (Insert Merge Field) и выделите в списке пункт Адрес1 (Addressi).

  5. Снова нажмите Enter и выделите в том же списке пункт Индекс (PostalCode).

  6. Переместите курсор в конец слова Уважаемый и нажмите клавишу Пробел.

  7. Выберите в списке Добавление поля слияния (Insert Merge Field) ноле Имя (First Name), нажмите клавишу Пробел и там же выберите поле Фамилия (LastName). Теперь главный документ должен выглядеть так, как показано на рис. 8.11.

Рис. 8.11. Главный документ с полями слияния

При слиянии Word позволяет не только перебрать все записи источника данных, но и отобрать некоторые из них. Для этого можно воспользоваться полями Word или запросом. Список Добавить поле Word (Insert Word Field) панели инструментов Слияние (Merge Mail) позволяет добавлять в документ следующие поля, выполняющие отбор записей источника данных на основе определенных правил:

  • ASK (Запрос) и FILLIN (Заполнение) генерируют паузу в процессе печати слияния и дают возможность вводить дополнительный текст в каждый экземпляр документа, например индивидуальный номер клиента или пароль;

  • IF... THEN... ELSE позволяет ввести условие и действие, которое выполняется в случае истинности или ложности условия;

  • MERGE REC (Номер записи) и MERGE SEQ (Номер по порядку ) добавляют в документ соответственно номер записи источника данных и порядковый номер экземпляра слияния. Если в слиянии участвуют не все записи источника данных, эти номера будут отличаться друг от друга;

  • NEXT (Следующая запись) и NEXTIF (Следующая запись, если) дают возможность напечатать в одном экземпляре документа информацию из нескольких последовательных записей источника данных;

  • SET BOOKMARK (Закладка) позволяет связать некоторый текст документа с закладкой, которую можно вставлять в документ любое число раз. Если изменится исходный текст, обозначенный закладкой, то он моментально обновится во всех точках вставки этой закладки;

  • SKIPIF (Пропустить запись, если) дает возможность ввести условие, в случае истинности которого текущая запись будет пропущена и не попадет в слияние.

Давайте добавим в слияние пару полей Word.

  8. Нажатием клавиш Ctrl+Home переместитесь в начало документа и выберите в панели инструментов Слияние (Merge Mail) команду Добавить поле Word > SKIPIF (Insert Word Field > Skip Record If).

Рис. 8.12. Добавление поля Word

  9. В раскрывающемся списке Поле (Field Name) выберите пункт Индекс (Postal- Code), как показано на рис. 8.12.

  10. В списке Оператор (Comparison) выберите пункт Равно (Equal To).

  11. Введите в поле Значение (Compare To) величину 114113.

  12. Щелкните на кнопке ОК. Теперь при слиянии в источнике данных будут пропущены те записи, в поле Индекс (PostalCode) которых записано значение 114113.

  13. Нажмите клавиши Ctrl+End, а затем два раза клавишу Enter. Выберите команду Добавить поле Word > MERGEREC (Insert Word Field > Merge Record #). С помощью этого поля вы сможете отследить, какие записи источника данных попадут в слияние. Теперь главный документ станет таким, как показано на рис. 8.13.

  14. Перейдите к следующему этапу создания рассылки, щелкнув на команде Далее: Просмотр писем (Next: Preview your letters) области задач.

  15. Щелкните на команде Изменить список (Edit Recipient List) в области задач, чтобы создать запрос, с помощью которого записи будут рассортированы по алфавиту имен получателей писем.

Рис. 8.13. Главный документ с полями Word

Давайте добавим правило отбора, оставляющее только адресатов из компании «Фантом». Щелкните на стрелке рядом с заголовком столбца Организация (Company Name) и в раскрывшемся списке выберите пункт Дополнительно (Advanced). В появившемся окне диалога есть две вкладки. Первая из них — Отбор записей (Filter Records), — представленная на рис. 8.14, позволяет фильтровать записи источника данных.

  16. В списке Поле (Field) выберите пункт Организация (Company).

  17. В списке Оператор (Comparison) оставьте вариант Равно (Equal To).

  18. В поле Значение (Compare To) введите текст Фантом.

  19. Раскройте вкладку Сортировка записей (Sort Records) и настройте ее параметры.

  20. Щелкните на кнопке ОК. Это обеспечит сортировку результата слияния по алфавиту фамилий адресатов, а затем по алфавиту их имен.

Примечание

Назначение одинаковых правил сортировки для писем и наклеек на конверты позволяет при отправке писем не тратить время на поиск нужного конверта. Конверты с наклейками будут лежать на вашем столе в том же порядке, что и письма.

  21. Щелчком на кнопке ОК закройте окно диалога Получатели и сохраните новую версию главного документа.


Упражнение 6. Печать результата слияния

У вас уже есть главный документ и связанный с ним источник данных, который отфильтрован и рассортирован с помощью запроса. Казалось бы, можно выполнить слияние и распечатать результат. Однако перед этим полезно проверить правильность слияния.

  1. Продолжая работать с документом предыдущего упражнения, щелкните на кнопке Поиск ошибок (Check For Errors) панели инструментов Слияние (Merge Mail). Откроется окно диалога с переключателем, имеющим три положения. Первое положение переключателя позволяет получить сообщения обо всех обнаруженных ошибках без выполнения слияния. Выбрав второе положение переключателя, вы получите как само слияние, так и сообщения обо всех ошибках в последовательно появляющихся окнах диалога. Третье положение переключателя инициирует генерацию слияния и в отдельном документе сохраняет отчет об ошибках.

  2. Выберите положение переключателя Создать только отчет об ошибках (Simulate The Merge And Report Errors In A New Document).

  3. Щелкните на кнопке ОК.

Рис. 8.14. Проверка корректности параметров слияния

Примечание

При правильном выполнении всех операций в слиянии не обнаружится никаких ошибок, но если, к примеру, в главном документе оказалось неверное поле данных, появится сообщение.

  4. Щелкните на кнопке Поля/Данные (View Merged Data). Вы увидите, что поля главного документа заменятся на данные одной из записей источника данных.

  5. С помощью кнопок Следующая запись (Next Record) и Предыдущая запись (Previous Record) панели инструментов слияния или соответствующих кнопок области задач просмотрите все экземпляры документа, соответствующие конкретным записям источника данных. Обратите внимание, что запись адресата Василий Решетников отсутствует, так как она отфильтрована запросом из-за несоответствия названия компании значению Фантом (см. табл. 8.1). Тем не менее в этом режиме предварительного просмотра вы сможете наблюдать запись адресата Петр Петров, которая при окончательном слиянии будет пропущена из-за наличия в главном документе поля SKIPIF (Пропустить запись, если) с соответствующим условием.

  6. Снова щелкните на кнопке Поля/Данные (View Merged Data), чтобы вернуть отображение полей.

  7. Наконец пришло время выполнить слияние. Щелкните на команде Далее: Завершение слияния (Next: Complete the Merge) чтобы перейти к последнему окну мастера.

  8. Вы можете выбрать один из четырех режимов слияния, воспользовавшись соответствующими кнопками панели инструментов Слияние (Mail Merge):

    • Слияние в новый документ (Merge to New Document) — создает документ Word, в котором последовательно на отдельных страницах размещаются все экземпляры, построенные на основе слияния;
    • Слияние при печати (Merge to Printer) —печатает результат слияния на принтер;
    • Объединить для отправки (Merge to E-Mail) — отправляет каждый экземпляр слияния нужному адресату но электронной почте. Чтобы указать, какое поле источника данных содержит адреса электронной почты, щелкните на этой кнопке и выберите нужное поле в списке Кому (То) открывшегося окна диалога Составные электронные письма (Merge to E-Mail), затем щелкните на кнопке ОК. (В этом же окне диалога можно ввести содержимое поля Тема (Subject) электронных сообщений, а также выбрать, какие именно записи вы хотите отправить.);
    • Объединить для отправки по факсу (Merge to Fax) — отправляет каждый экземпляр слияния нужному адресату по факсу.

  9. Щелкните на кнопке ОК. Результат слияния будет отправлен в новый документ, на принтер или по электронной почте. В первом случае вновь созданный документ появится на экране и его можно будет сохранить в отдельном файле на жестком диске.


Контрольное упражнение

В качестве контрольного упражнения попробуйте распечатать наклейки на конверты для писем, созданных на этом занятии с помощью слияния.

  1. Откройте документ Письмо.doc, а затем откройте окно Слияние (Mail Merge) области задач.

  2. В разделе Выбор типа документа (Select document type) выберите пункт Наклейки (Mailing Labels) и перейдите к следующему этапу.

  3. Щелкните на команде Параметры наклейки (Label Options).

  4. В окне диалога Параметры наклейки (Label Options) настроите формат наклеек на конверты. Перейдите к следующему этапу.

  5. Воспользуйтесь в качестве источника данных существующим файлом Гости.

    • Как указать в качестве источника данных существующий файл ?

  6. Добавьте в текст наклеек поля Имя (FirstName), Фамилия (LastName), Индекс (Postal Code) и Адрес1 (Addressi), снабдив их соответствующими подписями.

  7. Щелкните на кнопке Обновление всех наклеек (Update All Labels), чтобы копировать макет первой созданной наклейки на всех остальные.

  8. Перейдите к следующему этапу и просмотрите созданные наклейки.

    • Как перейти к нужной записи ?
  9. Проверьте слияние на отсутствие ошибок.
  10. Выполните слияние в новый документ.
    • Как быстро выполнить слияние в новый документ?

  11. Проверьте правописание и грамматику полученного документа. При этом не забывайте пропускать все собственные имена (но не вносите их в словарь Word).

12. Распечатайте слияние.


Подведение итогов

Вы научились пользоваться двумя дополнительными модулями Word — проверкой правописания и слиянием. Word имеет множество других не менее интересных вспомогательных инструментов, которые можно найти в меню Сервис (Tools). Попробуйте изучить их самостоятельно.

Это занятие было заключительным разделом части книги, посвященной приложению Word. На следующем занятии вы перейдете к изучению электронных таблиц Excel.

Для повседневной работы с программой Word XP рекомендуем пользоваться уже упоминавшейся книгой Б. Карпова «Microsoft Word 2002: справочник» («Питер», 2001).